summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-04 07:48:40 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-04 07:48:40 +0200
commitee12552b6ca9c278bd6606fb46e62d66fededab7 (patch)
tree3e77f460d8f31531f419861e5783866bd2dad2f0
parent53e0277c1bcf8adee3db20233803537bd85424fe (diff)
php-zendframework-zend-inputfilter: 2.5.5
-rw-r--r--php-zendframework-zend-inputfilter.spec31
1 files changed, 18 insertions, 13 deletions
diff --git a/php-zendframework-zend-inputfilter.spec b/php-zendframework-zend-inputfilter.spec
index b72f526..2513b28 100644
--- a/php-zendframework-zend-inputfilter.spec
+++ b/php-zendframework-zend-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3b9d3efbca7fbb34037bbc41fbf49c0f268554b7
+%global gh_commit 3208cddbb92df029230cde676a5c8e5a22b531c6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-inputfilter
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.4
+Version: 2.5.5
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -37,16 +37,16 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.5
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5.3
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# From composer, "require-dev": {
# "zendframework/zend-i18n": "~2.5",
# "zendframework/zend-servicemanager": "~2.5",
# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "^4.5"
BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.5
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -54,13 +54,13 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# From composer, "require": {
# "php": ">=5.5"
# "zendframework/zend-filter": "~2.5",
-# "zendframework/zend-validator": "~2.5",
+# "zendframework/zend-validator": "^2.5.3",
# "zendframework/zend-stdlib": "~2.5"
Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-filter) >= 2.5
Requires: php-composer(%{gh_owner}/zend-filter) < 3
-Requires: php-composer(%{gh_owner}/zend-validator) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-validator) >= 2.5.3
Requires: php-composer(%{gh_owner}/zend-validator) < 3
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
@@ -70,7 +70,7 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
%endif
%endif
-# From phpcompatinfo report for version 2.5.2
+# From phpcompatinfo report for version 2.5.5
Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
@@ -102,14 +102,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -133,6 +133,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Sep 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.5-1
+- update to 2.5.5
+- raise dependency on zend-validator ^2.5.3
+- raise build dependency on PHPUnit ^4.5
+
* Wed Aug 12 2015 Remi Collet <remi@fedoraproject.org> - 2.5.4-1
- update to 2.5.4