summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-22 09:12:34 +0200
committerRemi Collet <remi@remirepo.net>2017-05-22 09:12:34 +0200
commit3671c352d214eb6a40fd022684eeb62b875e82d3 (patch)
treec2dcd652cd4e17a5c7e050e4d3ec79cfa7427b5b
parentc9aaa3c9fa1aa9880ef59ab76da678fe3266a0f9 (diff)
v2.7.4
-rw-r--r--.gitignore7
-rw-r--r--composer.json6
-rw-r--r--php-zendframework-zend-inputfilter.spec60
3 files changed, 38 insertions, 35 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 787d525..b02be07 100644
--- a/composer.json
+++ b/composer.json
@@ -13,14 +13,14 @@
}
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^7.0 || ^5.6",
"zendframework/zend-filter": "^2.6",
"zendframework/zend-validator": "^2.6",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "phpunit/phpunit": "^4.8",
- "squizlabs/php_codesniffer": "^2.6.2",
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
},
"suggest": {
diff --git a/php-zendframework-zend-inputfilter.spec b/php-zendframework-zend-inputfilter.spec
index 4c736dc..42e2a19 100644
--- a/php-zendframework-zend-inputfilter.spec
+++ b/php-zendframework-zend-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0cf1bdcd8858a8583965310a7dae63ad75bd1237
+%global gh_commit 699ab4916e0aa73104e1f9ff068ef6d33c5f5fe4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-inputfilter
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.3
+Version: 2.7.4
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,31 +30,35 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5.3
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# From composer, "require-dev": {
-# "phpunit/phpunit": "^4.8",
-# "squizlabs/php_codesniffer": "^2.6.2",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^7.0 || ^5.6",
# "zendframework/zend-filter": "^2.6",
# "zendframework/zend-validator": "^2.6",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-filter) >= 2.6
Requires: php-composer(%{gh_owner}/zend-filter) < 3
@@ -95,8 +99,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -116,33 +118,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-if %{_bindir}/phpunit --atleast-version 5
-then
- # remirepo:3
- if [ -x "$PHPUNIT" ]; then
- $PHPUNIT --include-path=%{buildroot}%{php_home}
- fi
- : Skip test suite because PHPUnit is too recent
- exit 0
-fi
-
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-# remirepo:3
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+sed -e 's/PHPUnit_Framework_TestCase/PHPUnit\\Framework\\TestCase/' -i test/ConfigProviderTest.php
+ret=0
+# PHP 7.2: https://github.com/zendframework/zend-inputfilter/issues/140
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -151,6 +142,11 @@ rm -rf %{buildroot}
%changelog
+* Mon May 22 2017 Remi Collet <remi@remirepo.net> - 2.7.4-1
+- Update to 2.7.4
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 2.7.3-1
- update to 2.7.3