summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-i18n.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-i18n.spec')
-rw-r--r--php-zendframework-zend-i18n.spec67
1 files changed, 49 insertions, 18 deletions
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 7b9aacb..7852d9c 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d3431e29cc00c2a1c6704e601d4371dbf24f6a31
+%global gh_commit cfdb658121e0d7eb969a498c2f67f1eacaab9c63
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.4
-Release: 4%{?dist}
+Version: 2.8.0
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
License: BSD
@@ -29,9 +29,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# https://github.com/zendframework/zend-i18n/pull/91
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-i18n/pull/91.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -41,9 +38,8 @@ BuildRequires: php-date
BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "zendframework/zend-cache": "^2.6.1",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.6",
@@ -52,46 +48,76 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
# "zendframework/zend-validator": "^2.6",
# "zendframework/zend-view": "^2.6.3"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-composer(%{gh_owner}/zend-cache) >= 2.6.1 with php-composer(%{gh_owner}/zend-cache) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-config) >= 2.6 with php-composer(%{gh_owner}/zend-config) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-composer(%{gh_owner}/zend-eventmanager) < 4)
+BuildRequires: (php-composer(%{gh_owner}/zend-filter) >= 2.5 with php-composer(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-composer(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-composer(%{gh_owner}/zend-validator) >= 2.6 with php-composer(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-composer(%{gh_owner}/zend-view) >= 2.6.3 with php-composer(%{gh_owner}/zend-view) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:20
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-cache) < 3
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
+BuildRequires: php-composer(%{gh_owner}/zend-config) < 3
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) < 4
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
+BuildRequires: php-composer(%{gh_owner}/zend-filter) < 3
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) < 4
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
+BuildRequires: php-composer(%{gh_owner}/zend-validator) < 3
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-view) < 3
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
-BuildRequires: phpunit6
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.0 || ^5.6",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+%else
+# remirepo:4
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+%endif
# From composer, "suggest": {
# "ext-intl": "Required for most features of Zend\\I18n; included in default builds of PHP",
# "zendframework/zend-cache": "Zend\\Cache component",
# "zendframework/zend-config": "Zend\\Config component",
# "zendframework/zend-eventmanager": "You should install this package to use the events in the translator",
# "zendframework/zend-filter": "You should install this package to use the provided filters",
+# "zendframework/zend-i18n-resources": "Translation resources",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
# "zendframework/zend-validator": "You should install this package to use the provided validators",
# "zendframework/zend-view": "You should install this package to use the provided view helpers",
# "zendframework/zend-resources": "Translation resources"
-%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-cache)
Suggests: php-composer(%{gh_owner}/zend-config)
Suggests: php-composer(%{gh_owner}/zend-eventmanager)
Suggests: php-composer(%{gh_owner}/zend-filter)
+Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
Suggests: php-composer(%{gh_owner}/zend-servicemanager)
Suggests: php-composer(%{gh_owner}/zend-validator)
Suggests: php-composer(%{gh_owner}/zend-view)
-Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
-%endif
%endif
Requires: php-intl
# From phpcompatinfo report for version 2.5.1
@@ -123,7 +149,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -167,9 +192,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -187,6 +213,11 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- update to 2.8.0
+- switch to phpunit6 or phpunit7
+- use range dependencies on F27+
+
* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 2.7.4-4
- fix FTBFS from Koschei, path from
https://github.com/zendframework/zend-i18n/pull/91