summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-12 08:57:41 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-12 08:57:41 +0100
commit7bb7679cd5754bfa49ad1bbb787005818af5344e (patch)
tree8337c81cedc6052703d645d8946355f4768c68bf
parent2a71e67c94d9b0fa6de8515965366e2c9f9feb0d (diff)
php-zendframework-zend-i18n: 2.6.0
-rw-r--r--php-zendframework-zend-i18n.spec51
1 files changed, 28 insertions, 23 deletions
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 3681c43..c5400a2 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 509271eb7947e4aabebfc376104179cffea42696
+%global gh_commit 41c8bf1ed8eb5e81e30b666f2477ecd4d162c645
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,28 +34,28 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
-# "zendframework/zend-cache": "~2.5",
-# "zendframework/zend-config": "~2.5",
-# "zendframework/zend-eventmanager": "~2.5",
-# "zendframework/zend-filter": "~2.5",
-# "zendframework/zend-servicemanager": "~2.5",
-# "zendframework/zend-validator": "~2.5",
-# "zendframework/zend-view": "~2.5",
+# "zendframework/zend-cache": "^2.5",
+# "zendframework/zend-config": "^2.6",
+# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
+# "zendframework/zend-filter": "^2.6.1",
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
+# "zendframework/zend-validator": "^2.5",
+# "zendframework/zend-view": "^2.5",
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.5
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
@@ -64,12 +64,12 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
-# "zendframework/zend-stdlib": "~2.5"
+# "php": "^5.5 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.3.23
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
-Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "ext-intl": "Required for most features of Zend\\I18n; included in default builds of PHP",
# "zendframework/zend-cache": "Zend\\Cache component",
@@ -132,14 +132,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -168,5 +168,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib >= 2.7
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package \ No newline at end of file