summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-13 10:27:09 +0100
committerRemi Collet <remi@remirepo.net>2018-02-13 10:27:09 +0100
commit4de314b045510c2292adda4ab263c9c8fd7f6358 (patch)
treed98cb3a047ae27e0d42e3ba088cd3c652ee26619
parent4c75e50d8de345a1975f2248c3863395a00b99b8 (diff)
fix FTBFS from Koschei, path from https://github.com/zendframework/zend-i18n/pull/91
always use phpunit6
-rw-r--r--php-zendframework-zend-i18n.spec33
1 files changed, 16 insertions, 17 deletions
diff --git a/php-zendframework-zend-i18n.spec b/php-zendframework-zend-i18n.spec
index 3a931d3..7b9aacb 100644
--- a/php-zendframework-zend-i18n.spec
+++ b/php-zendframework-zend-i18n.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-zendframework-zend-i18n
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,15 +21,17 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.7.4
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+# https://github.com/zendframework/zend-i18n/pull/91
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-i18n/pull/91.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -57,16 +59,11 @@ BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
+BuildRequires: phpunit6
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
-BuildRequires: php-fedora-autoloader-devel
%endif
+BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.0 || ^5.6",
@@ -126,6 +123,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -157,9 +155,6 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
-# See https://github.com/zendframework/zend-i18n/issues/14
-sed -e '/de_AT/d' -i test/View/Helper/CurrencyFormatTest.php
-
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -172,10 +167,9 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
- if which $cmdarg; then
- set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
fi
done
exit $ret
@@ -193,6 +187,11 @@ exit $ret
%changelog
+* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 2.7.4-4
+- fix FTBFS from Koschei, path from
+ https://github.com/zendframework/zend-i18n/pull/91
+- always use phpunit6
+
* Fri Nov 24 2017 Remi Collet <remi@remirepo.net> - 2.7.4-3
- switch from zend-loader to fedora/autoloader