summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-i18n-resources.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-i18n-resources.spec')
-rw-r--r--php-zendframework-zend-i18n-resources.spec49
1 files changed, 33 insertions, 16 deletions
diff --git a/php-zendframework-zend-i18n-resources.spec b/php-zendframework-zend-i18n-resources.spec
index 11f8da8..1e712a0 100644
--- a/php-zendframework-zend-i18n-resources.spec
+++ b/php-zendframework-zend-i18n-resources.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-i18n-resources
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit fe53e1c96654c4fc89975d14ed13ccbce6c08179
+%global gh_commit 530ab0af94ed1dd542665e6041d92297f7347ef3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-i18n-resources
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.2
-Release: 5%{?dist}
+Version: 2.6.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -33,15 +33,26 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
-BuildRequires: php-cli
+BuildRequires: php(language) >= 5.6
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:4
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: phpunit >= 5.7.27
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": ">=5.5"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.5.1
@@ -62,7 +73,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-mv LICENSE.txt LICENSE
+mv LICENSE.md LICENSE
%build
@@ -84,13 +95,14 @@ cat << EOF | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php';
EOF
-php -r '
- require "vendor/autoload.php";
- use Zend\I18n\Translator\Resources;
- $fic = Resources::getBasePath().sprintf(Resources::getPatternForCaptcha(), "fr");
- echo realpath($fic)."\n";
- exit (file_exists($fic) ? 0 : 1);
-'
+ret=0
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
@@ -107,6 +119,11 @@ php -r '
%changelog
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+- run upstream test suite
+
* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.5.2-5
- switch from zend-loader to fedora/autoloader