summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commitfd5b3138230b54f649731f2abaf094ba1c8721d9 (patch)
treed1ce8a84e9650233f8ccd9261ffc9bcab7d9b9ac
parentabd2718bb859a2bf6be731a0211af4d7730e17d1 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-http.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-zendframework-zend-http.spec b/php-zendframework-zend-http.spec
index 7c06480..f3a9190 100644
--- a/php-zendframework-zend-http.spec
+++ b/php-zendframework-zend-http.spec
@@ -125,7 +125,12 @@ Zend\Loader\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif