summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-27 07:59:21 +0200
committerRemi Collet <remi@remirepo.net>2018-04-27 07:59:21 +0200
commitc916bfa63a46438853f57ae57292f7b4989a369e (patch)
treee9e3af83a4f21bffee0f1d9e32c536c889b69c1f
parent8c125d05f0f00f1a7e4156ee5e1d8d8da66be6e5 (diff)
update to 2.8.0
use range dependencies on F27+ switch to phpunit6 or phpunit7
-rw-r--r--composer.json25
-rw-r--r--php-zendframework-zend-http.spec63
2 files changed, 58 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index f37a9b1..07e1d89 100644
--- a/composer.json
+++ b/composer.json
@@ -1,7 +1,6 @@
{
"name": "zendframework/zend-http",
- "description": "provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests",
- "homepage": "https://github.com/zendframework/zend-http",
+ "description": "Provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests",
"license": "BSD-3-Clause",
"keywords": [
"zf",
@@ -11,16 +10,13 @@
"HTTP client"
],
"support": {
- "docs": "https://docs.zendframework.com/zend-http",
+ "docs": "https://docs.zendframework.com/zend-http/",
"issues": "https://github.com/zendframework/zend-http/issues",
"source": "https://github.com/zendframework/zend-http",
"rss": "https://github.com/zendframework/zend-http/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
- "config": {
- "sort-packages": true
- },
"require": {
"php": "^5.6 || ^7.0",
"zendframework/zend-loader": "^2.5.1",
@@ -29,10 +25,13 @@
"zendframework/zend-validator": "^2.10.1"
},
"require-dev": {
- "phpunit/phpunit": "^6.4.1 || ^5.7.15",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^3.1 || ^2.6"
},
+ "suggest": {
+ "paragonie/certainty": "For automated management of cacert.pem"
+ },
"autoload": {
"psr-4": {
"Zend\\Http\\": "src/"
@@ -43,10 +42,13 @@
"ZendTest\\Http\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
}
},
"scripts": {
@@ -57,7 +59,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-http.spec b/php-zendframework-zend-http.spec
index 3a01db6..08fbb9b 100644
--- a/php-zendframework-zend-http.spec
+++ b/php-zendframework-zend-http.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-http
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 78aa510c0ea64bfb2aa234f50c4f232c9531acfa
+%global gh_commit f48b276ffa11b48dd1ae3c6bc306d6ed7958ef51
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-http
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -42,19 +41,33 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-zlib
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^3.1 || ^2.6"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/zend-loader) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.5 with php-autoloader(%{gh_owner}/zend-config) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:14
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-loader) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^6.4.1 || ^5.7.15",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^3.1 || ^2.6"
+BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.5
-%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
+BuildRequires: phpunit6 >= 6.5.8
%endif
%endif
# Autoloader
@@ -68,18 +81,27 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-validator": "^2.10.1"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/zend-loader) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:10
+%else
Requires: php-autoloader(%{gh_owner}/zend-loader) < 3
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+Requires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
Requires: php-autoloader(%{gh_owner}/zend-uri) < 3
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+Requires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5
Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.8.0
Requires: php-ctype
Requires: php-curl
Requires: php-date
@@ -140,10 +162,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} || ret=1
fi
done
exit $ret
@@ -161,6 +183,11 @@ exit $ret
%changelog
+* Fri Apr 27 2018 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- update to 2.8.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.7.0-2
- switch from zend-loader to fedora/autoloader