summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json9
-rw-r--r--php-zendframework-zend-form.spec23
2 files changed, 15 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index a4470fd..ee89f26 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"require": {
"php": "^5.6 || ^7.0",
"zendframework/zend-inputfilter": "^2.8",
- "zendframework/zend-hydrator": "^1.1 || ^2.1",
+ "zendframework/zend-hydrator": "^1.1 || ^2.1 || ^3.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
@@ -57,6 +57,9 @@
]
},
"autoload-dev": {
+ "files": [
+ "test/_autoload.php"
+ ],
"psr-4": {
"ZendTest\\Form\\": "test/"
}
@@ -66,8 +69,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.12.x-dev",
- "dev-develop": "2.13.x-dev"
+ "dev-master": "2.13.x-dev",
+ "dev-develop": "2.14.x-dev"
},
"zf": {
"component": "Zend\\Form",
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 83af254..40503ee 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 565fb4f4bb3e0dbeea0173c923c4a8be77de9441
+%global gh_commit c713a12ccbd43148b71c9339e171ca11e3f8a1da
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -22,7 +22,7 @@
# TODO: re-enable phpunit6 when 6.5 will be available
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -85,7 +85,7 @@ BuildRequires: php-phpunit-PHPUnit >= 5.7.23
# Missing
BuildRequires: php-composer(ircmaxell/random-lib)
# Autoloader
-#BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
# For dependencies autoloader
BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
@@ -93,14 +93,14 @@ BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "zendframework/zend-inputfilter": "^2.8",
-# "zendframework/zend-hydrator": "^1.1 || ^2.1",
+# "zendframework/zend-hydrator": "^1.1 || ^2.1 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.8
Requires: php-composer(%{gh_owner}/zend-inputfilter) < 3
Requires: php-composer(%{gh_owner}/zend-hydrator) >= 1.1
-Requires: php-composer(%{gh_owner}/zend-hydrator) < 3
+Requires: php-composer(%{gh_owner}/zend-hydrator) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
@@ -111,15 +111,6 @@ Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3, required to use the form factories or provide services",
# "zendframework/zend-view": "^2.6.2, required for using the zend-form view helpers",
# "zendframework/zendservice-recaptcha": "in order to use the ReCaptcha form element"
-%if 0%{?fedora} >= 21
-Suggests: php-composer(%{gh_owner}/zend-captcha)
-Suggests: php-composer(%{gh_owner}/zend-code)
-Suggests: php-composer(%{gh_owner}/zend-eventmanager)
-Suggests: php-composer(%{gh_owner}/zend-i18n)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-view)
-Suggests: php-composer(%{gh_owner}/zendservice-recaptcha)
-%endif
%endif
# From phpcompatinfo report for version 2.6.0
Requires: php-date
@@ -174,6 +165,7 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once dirname(__DIR__) . '/test/_autoload.php';
EOF
ret=0
@@ -199,6 +191,9 @@ exit $ret
%changelog
+* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+
* Wed May 23 2018 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0