summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-08 09:15:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-08 09:15:11 +0200
commitf419d7fad2bf5cc547f718d8a4d326be7e6215c4 (patch)
treef3c8a64fdd3ed941b88a94f33b9e3f7a2b70f9f4
parente0e5efcaa71812310a8489342afc21afeeb68b0d (diff)
php-zendframework-zend-form: 2.8.0
-rw-r--r--composer.json12
-rw-r--r--php-zendframework-zend-form.spec21
2 files changed, 21 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 26c5c12..4629a73 100644
--- a/composer.json
+++ b/composer.json
@@ -21,13 +21,13 @@
"require-dev": {
"doctrine/annotations": "~1.0",
"zendframework/zend-cache": "^2.6.1",
- "zendframework/zend-captcha": "^2.5",
+ "zendframework/zend-captcha": "^2.5.4",
"zendframework/zend-code": "^2.6",
"zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
"zendframework/zend-filter": "^2.6",
"zendframework/zend-i18n": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-session": "^2.5",
+ "zendframework/zend-session": "^2.6.2",
"zendframework/zend-text": "^2.6",
"zendframework/zend-validator": "^2.6",
"zendframework/zend-view": "^2.6.2",
@@ -50,8 +50,12 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "dev-master": "2.8-dev",
+ "dev-develop": "2.9-dev"
+ },
+ "zf": {
+ "component": "Zend\\Form",
+ "config-provider": "Zend\\Form\\ConfigProvider"
}
},
"autoload-dev": {
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 25b43bc..c76f84d 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7c46b6a2d04d12aacd9c32bb021d0d9d0354d5d5
+%global gh_commit 1b881dc4bc366d68ca88aaa946c788519eeb83f1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -45,13 +45,13 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
# "doctrine/annotations": "~1.0",
# "zendframework/zend-cache": "^2.6.1",
-# "zendframework/zend-captcha": "^2.5",
+# "zendframework/zend-captcha": "^2.5.4",
# "zendframework/zend-code": "^2.6",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-filter": "^2.6",
# "zendframework/zend-i18n": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-session": "^2.5",
+# "zendframework/zend-session": "^2.6.2",
# "zendframework/zend-text": "^2.6",
# "zendframework/zend-validator": "^2.6",
# "zendframework/zend-view": "^2.6.2",
@@ -60,19 +60,20 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "phpunit/PHPUnit": "~4.0"
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-captcha) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-captcha) >= 2.5.4
BuildRequires: php-composer(%{gh_owner}/zend-code) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.2
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
# Missing
BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
+BuildRequires: php-composer(ircmaxell/random-lib)
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -162,8 +163,9 @@ EOF
%{_bindir}/phpunit -d memory_limit=1G --include-path=%{buildroot}%{php_home}
+# remirepo:3
if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+ php70 %{_bindir}/phpunit -d memory_limit=1G --include-path=%{buildroot}%{php_home}
fi
%else
: Test suite disabled
@@ -184,6 +186,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 8 2016 Remi Collet <remi@fedoraproject.org> - 2.8.0-1
+- update to 2.8.0
+
* Tue Feb 23 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
- update to 2.7.0
- raise dependency on zend-inputfilter >= 2.6
@@ -202,4 +207,4 @@ rm -rf %{buildroot}
- raise minimum php version to 5.5
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
-- initial package \ No newline at end of file
+- initial package