summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-07 09:14:15 +0100
committerRemi Collet <remi@remirepo.net>2017-12-07 09:14:15 +0100
commitd6b4f5e5bbaa660e44fdb179e651a7647c10ea46 (patch)
treed3fd8d91ba80027ba9955ed45019857117ed24e3
parent45f68a9fdfee53fa54a7d558b43a867844f67b9e (diff)
Update to 2.11.0
temporarily switch back to phpunit v5 raise dependency on zend-inputfilter 2.8 raise dependency on zend-session 2.8.1
-rw-r--r--composer.json56
-rw-r--r--fbda16c3e87725ac64418e8578d167320855f20b.patch37
-rw-r--r--php-zendframework-zend-form.spec37
3 files changed, 52 insertions, 78 deletions
diff --git a/composer.json b/composer.json
index b033262..e76be2f 100644
--- a/composer.json
+++ b/composer.json
@@ -1,23 +1,23 @@
{
"name": "zendframework/zend-form",
- "description": " ",
+ "description": "Validate and display simple and complex forms, casting forms to business objects and vice versa",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"form"
],
- "homepage": "https://github.com/zendframework/zend-form",
- "autoload": {
- "psr-4": {
- "Zend\\Form\\": "src/"
- },
- "files": [
- "autoload/formElementManagerPolyfill.php"
- ]
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-form/",
+ "issues": "https://github.com/zendframework/zend-form/issues",
+ "source": "https://github.com/zendframework/zend-form",
+ "rss": "https://github.com/zendframework/zend-form/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^7.0 || ^5.6",
- "zendframework/zend-inputfilter": "^2.6",
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-inputfilter": "^2.8",
"zendframework/zend-hydrator": "^1.1 || ^2.1",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
@@ -31,12 +31,12 @@
"zendframework/zend-filter": "^2.6",
"zendframework/zend-i18n": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-session": "^2.6.2",
+ "zendframework/zend-session": "^2.8.1",
"zendframework/zend-text": "^2.6",
"zendframework/zend-validator": "^2.6",
"zendframework/zend-view": "^2.6.2",
"zendframework/zendservice-recaptcha": "^3.0.0",
- "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+ "phpunit/phpunit": "^5.7.23 || ^6.5.3",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
@@ -48,17 +48,13 @@
"zendframework/zend-view": "^2.6.2, required for using the zend-form view helpers",
"zendframework/zendservice-recaptcha": "in order to use the ReCaptcha form element"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.10-dev",
- "dev-develop": "2.11-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\Form\\": "src/"
},
- "zf": {
- "component": "Zend\\Form",
- "config-provider": "Zend\\Form\\ConfigProvider"
- }
+ "files": [
+ "autoload/formElementManagerPolyfill.php"
+ ]
},
"autoload-dev": {
"psr-4": {
@@ -66,7 +62,17 @@
}
},
"config": {
- "process-timeout": 0
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.11.x-dev",
+ "dev-develop": "2.12.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Form",
+ "config-provider": "Zend\\Form\\ConfigProvider"
+ }
},
"scripts": {
"check": [
diff --git a/fbda16c3e87725ac64418e8578d167320855f20b.patch b/fbda16c3e87725ac64418e8578d167320855f20b.patch
deleted file mode 100644
index 31b93c8..0000000
--- a/fbda16c3e87725ac64418e8578d167320855f20b.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From fbda16c3e87725ac64418e8578d167320855f20b Mon Sep 17 00:00:00 2001
-From: Filippo Tessarotto <zoeslam@gmail.com>
-Date: Thu, 22 Jun 2017 14:57:02 +0200
-Subject: [PATCH] Prepare to PHP 7.2
-
----
- src/Form.php | 2 +-
- test/View/Helper/FormSelectTest.php | 3 ++-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/Form.php b/src/Form.php
-index c9c1a43f..937d9265 100644
---- a/src/Form.php
-+++ b/src/Form.php
-@@ -328,7 +328,7 @@ public function setHydrator(HydratorInterface $hydrator)
- * @param array $values
- * @return mixed
- */
-- public function bindValues(array $values = [])
-+ public function bindValues(array $values = [], array $validationGroup = null)
- {
- if (! is_object($this->object)) {
- if ($this->baseFieldset === null || $this->baseFieldset->allowValueBinding() == false) {
-diff --git a/test/View/Helper/FormSelectTest.php b/test/View/Helper/FormSelectTest.php
-index 5988ef78..3db96928 100644
---- a/test/View/Helper/FormSelectTest.php
-+++ b/test/View/Helper/FormSelectTest.php
-@@ -216,7 +216,8 @@ public function testScalarOptionValues($options)
- $element = new SelectElement('foo');
- $element->setValueOptions($options);
- $markup = $this->helper->render($element);
-- list($value, $label) = each($options);
-+ $value = key($options);
-+ $label = current($options);
- $this->assertRegexp(sprintf('#option .*?value="%s"#', (string) $value), $markup);
- }
-
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 29f7acf..3a813ab 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 252db729887844025772bb8045f8df605850ed9c
+%global gh_commit b68a9f07d93381613b68817091d0505ca94d3363
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -19,9 +19,11 @@
%global with_tests 0%{!?_without_tests:1}
%endif
+# TODO: re-enable phpunit6 when 6.5 will be available
+
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.2
-Release: 3%{?dist}
+Version: 2.11.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +32,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://github.com/zendframework/zend-form/commit/fbda16c3e87725ac64418e8578d167320855f20b.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -42,7 +42,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# Temporary, see https://github.com/zendframework/zend-math/issues/23
BuildRequires: php-mcrypt
-BuildRequires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.8
BuildRequires: php-composer(%{gh_owner}/zend-hydrator) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
@@ -55,12 +55,12 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-filter": "^2.6",
# "zendframework/zend-i18n": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-session": "^2.6.2",
+# "zendframework/zend-session": "^2.8.1",
# "zendframework/zend-text": "^2.6",
# "zendframework/zend-validator": "^2.6",
# "zendframework/zend-view": "^2.6.2",
# "zendframework/zendservice-recaptcha": "^3.0.0",
-# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
+# "phpunit/phpunit": "^5.7.23 || ^6.5.3",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
@@ -71,16 +71,17 @@ BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8.1
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.2
-%if 0%{?fedora} >= 26
+%if 0
%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.3
%else
%global phpunit %{_bindir}/phpunit
+BuildRequires: php-phpunit-PHPUnit >= 5.7.23
%endif
-BuildRequires: %{phpunit}
# Missing
BuildRequires: php-composer(ircmaxell/random-lib)
# Autoloader
@@ -90,13 +91,13 @@ BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
-# "php": "^7.0 || ^5.6",
-# "zendframework/zend-inputfilter": "^2.6",
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-inputfilter": "^2.8",
# "zendframework/zend-hydrator": "^1.1 || ^2.1",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.6
+Requires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.8
Requires: php-composer(%{gh_owner}/zend-inputfilter) < 3
Requires: php-composer(%{gh_owner}/zend-hydrator) >= 1.1
Requires: php-composer(%{gh_owner}/zend-hydrator) < 3
@@ -142,7 +143,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -177,7 +177,6 @@ require_once '%{php_home}/Zend/autoload.php';
EOF
ret=0
-# 7.2: https://github.com/zendframework/zend-form/issues/157
for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
@@ -200,6 +199,12 @@ exit $ret
%changelog
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- Update to 2.11.0
+- temporarily switch back to phpunit v5
+- raise dependency on zend-inputfilter 2.8
+- raise dependency on zend-session 2.8.1
+
* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.10.2-3
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/zendframework/zend-form/pull/171