summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-27 07:27:20 +0200
committerRemi Collet <remi@remirepo.net>2017-04-27 07:27:20 +0200
commit6a098dd89e68718e998381488cea5eb6aab87309 (patch)
treea7a02da607b10daab1b1d3e86fb29b4418acdc5d
parente1034493bf0f6e0297fea4717593269fa890a917 (diff)
v2.10.1
-rw-r--r--.gitignore7
-rw-r--r--composer.json4
-rw-r--r--php-zendframework-zend-form.spec53
3 files changed, 33 insertions, 31 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 2ecc6d6..b033262 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,7 @@
]
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^7.0 || ^5.6",
"zendframework/zend-inputfilter": "^2.6",
"zendframework/zend-hydrator": "^1.1 || ^2.1",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
@@ -36,7 +36,7 @@
"zendframework/zend-validator": "^2.6",
"zendframework/zend-view": "^2.6.2",
"zendframework/zendservice-recaptcha": "^3.0.0",
- "phpunit/phpunit": "^4.8",
+ "phpunit/phpunit": "^6.0.8 || ^5.7.15",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
diff --git a/php-zendframework-zend-form.spec b/php-zendframework-zend-form.spec
index 282ae52..17bd55f 100644
--- a/php-zendframework-zend-form.spec
+++ b/php-zendframework-zend-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ca2b2f9e1bdc5511d06967d755cbb793708a2d7b
+%global gh_commit 1ca3ab771abd533d440646ec1cc082fccad976a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-form
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.0
+Version: 2.10.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,11 +30,10 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-intl
BuildRequires: php-pcre
@@ -59,7 +58,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# "zendframework/zend-validator": "^2.6",
# "zendframework/zend-view": "^2.6.2",
# "zendframework/zendservice-recaptcha": "^3.0.0",
-# "phpunit/phpunit": "^4.8",
+# "phpunit/phpunit": "^6.0.8 || ^5.7.15",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
@@ -74,7 +73,12 @@ BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.2
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Missing
BuildRequires: php-composer(ircmaxell/random-lib)
# Autoloader
@@ -84,11 +88,11 @@ BuildRequires: php-zendframework-zend-loader >= 2.5.1-3
%endif
# From composer, "require": {
-# "php": ">=5.5",
+# "php": "^7.0 || ^5.6",
# "zendframework/zend-inputfilter": "^2.6",
# "zendframework/zend-hydrator": "^1.1 || ^2.1",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-inputfilter) >= 2.6
Requires: php-composer(%{gh_owner}/zend-inputfilter) < 3
@@ -145,8 +149,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -171,33 +173,21 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit -d memory_limit=1G || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit -d memory_limit=1G || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit -d memory_limit=1G --verbose
-# remirepo:2
-fi
+# 7.2: https://github.com/zendframework/zend-form/issues/157
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} -d memory_limit=1G || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -207,6 +197,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 27 2017 Remi Collet <remi@remirepo.net> - 2.10.1-1
+- Update to 2.10.1
+- raise minimum php version to 5.6
+- use phpunit6 on F26+
+
* Thu Mar 2 2017 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- raise dependency on zend-captcha 2.7.1