summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json58
-rw-r--r--php-zendframework-zend-file.spec46
2 files changed, 56 insertions, 48 deletions
diff --git a/composer.json b/composer.json
index 3fb0b6a..ef2a081 100644
--- a/composer.json
+++ b/composer.json
@@ -1,46 +1,42 @@
{
"name": "zendframework/zend-file",
- "description": " ",
+ "description": "Locate PHP classfiles",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"file"
],
- "homepage": "https://github.com/zendframework/zend-file",
- "config": {
- "sort-packages": true
- },
- "autoload": {
- "psr-4": {
- "Zend\\File\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-file/",
+ "issues": "https://github.com/zendframework/zend-file/issues",
+ "source": "https://github.com/zendframework/zend-file",
+ "rss": "https://github.com/zendframework/zend-file/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/phpunit": "~4.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-filter": "^2.6.1",
- "zendframework/zend-i18n": "^2.6",
+ "zendframework/zend-filter": "^2.7.2",
+ "zendframework/zend-i18n": "^2.7.4",
"zendframework/zend-progressbar": "^2.5.2",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-session": "^2.6.2",
- "zendframework/zend-validator": "^2.6"
+ "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+ "zendframework/zend-session": "^2.8",
+ "zendframework/zend-validator": "^2.10.1"
},
"suggest": {
"zendframework/zend-filter": "Zend\\Filter component",
"zendframework/zend-i18n": "Zend\\I18n component",
"zendframework/zend-validator": "Zend\\Validator component"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\File\\": "src/"
}
},
"autoload-dev": {
@@ -48,6 +44,15 @@
"ZendTest\\File\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
@@ -56,7 +61,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-file.spec b/php-zendframework-zend-file.spec
index 769a42b..f5b1e0d 100644
--- a/php-zendframework-zend-file.spec
+++ b/php-zendframework-zend-file.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 888fd4852432ee61ffd48a66b6812387b4f83c02
+%global gh_commit 28ec81a9147cd76b9d6cdce519ce96858fbab5f0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-file
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -33,41 +33,40 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-fileinfo
BuildRequires: php-hash
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tokenizer
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "require-dev": {
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/phpunit": "~4.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-filter": "^2.6.1",
-# "zendframework/zend-i18n": "^2.6",
+# "zendframework/zend-filter": "^2.7.2",
+# "zendframework/zend-i18n": "^2.7.4",
# "zendframework/zend-progressbar": "^2.5.2",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-session": "^2.6.2",
-# "zendframework/zend-validator": "^2.6"
-BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-validator": "^2.10.1"
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7
+BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.7.2
+BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.7.4
BuildRequires: php-composer(%{gh_owner}/zend-progressbar) >= 2.5.2
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "suggest": {
# "zendframework/zend-filter": "Zend\\Filter component",
# "zendframework/zend-i18n": "Zend\\I18n component",
@@ -148,6 +147,11 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 5.6
+- raise dependency on zend-stdlib 2.7.7
+
* Wed Jan 11 2017 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1