summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-file.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-17 16:40:18 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-17 16:40:18 +0100
commitd919d8fb3402bae74b02c39fcbe07047562aef3b (patch)
treebc38058d4553724b2b46c5bce3d2dec43416de41 /php-zendframework-zend-file.spec
parente36197c18ca35aa6be7f8e293099c641ce6e83b7 (diff)
php-zendframework-zend-file: 2.5.2
Diffstat (limited to 'php-zendframework-zend-file.spec')
-rw-r--r--php-zendframework-zend-file.spec33
1 files changed, 16 insertions, 17 deletions
diff --git a/php-zendframework-zend-file.spec b/php-zendframework-zend-file.spec
index aa74249..a3c7d13 100644
--- a/php-zendframework-zend-file.spec
+++ b/php-zendframework-zend-file.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e8e76f343e1ca12f615c649e2e2f95e86254184d
+%global gh_commit e2cb613512f5d1c82448601071e47df5c050e6af
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-file
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
-Release: 3%{?dist}
+Version: 2.5.2
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,14 +30,11 @@ URL: http://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch1: %{name}-upstream.patch
-Patch2: %{name}-pr14.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-fileinfo
BuildRequires: php-hash
BuildRequires: php-pcre
@@ -65,9 +62,9 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
+# "php": "^5.5 || ^7.0",
# "zendframework/zend-stdlib": "~2.5"
-Requires: php(language) >= 5.3.23
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
@@ -100,9 +97,6 @@ Zend\File is a component used to manage file transfer and class autoloading.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch1 -p1
-%patch2 -p1
-
%build
# Empty build section, nothing required
@@ -118,18 +112,19 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+# Notice: test fail in CLI mode with APC
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
if which php70; then
@@ -154,6 +149,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Feb 17 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP >= 5.5
+
* Sun Feb 14 2016 Remi Collet <remi@fedoraproject.org> - 2.5.1-3
- add patch for newer zend-filter