summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-07 08:21:27 +0100
committerRemi Collet <remi@remirepo.net>2019-02-07 08:21:27 +0100
commit221c5fec1f2cf79f8aa389186ec5839ba12b4682 (patch)
treeee48a10be3efc55a732520446fc848b0d7854260
parent6f93e56523fa73e006454596d3d3d88425d7378e (diff)
v2.8.3 (no change)
-rw-r--r--46.patch21
-rw-r--r--php-zendframework-zend-file.spec13
2 files changed, 31 insertions, 3 deletions
diff --git a/46.patch b/46.patch
new file mode 100644
index 0000000..53ef673
--- /dev/null
+++ b/46.patch
@@ -0,0 +1,21 @@
+From 90304944c400db475f686945abac9b6dad4c9385 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 5 Feb 2019 09:22:44 +0100
+Subject: [PATCH] fix test for zend-validator 1.11
+
+---
+ test/Transfer/Adapter/HttpTest.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/Transfer/Adapter/HttpTest.php b/test/Transfer/Adapter/HttpTest.php
+index 6af43f0..34ec79a 100644
+--- a/test/Transfer/Adapter/HttpTest.php
++++ b/test/Transfer/Adapter/HttpTest.php
+@@ -334,6 +334,6 @@ public function testValidationOfPhpExtendsFormError()
+ $_FILES = [];
+ $adapter = new HttpTestMockAdapter();
+ $this->assertFalse($adapter->isValidParent());
+- $this->assertContains('exceeds the defined ini size', current($adapter->getMessages()));
++ $this->assertContains('exceeds', current($adapter->getMessages()));
+ }
+ }
diff --git a/php-zendframework-zend-file.spec b/php-zendframework-zend-file.spec
index 288b635..0f54a43 100644
--- a/php-zendframework-zend-file.spec
+++ b/php-zendframework-zend-file.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-file
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d267733fbc3a15c9ca82708cf6e634e2fabb29e7
+%global gh_commit b6e167e056ce8594be1db93460cddb503de341ed
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-file
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.2
+Version: 2.8.3
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -186,6 +186,13 @@ exit $ret
%changelog
+* Thu Feb 7 2019 Remi Collet <remi@remirepo.net> - 2.8.3-1
+- update to 2.8.3 (no change)
+
+* Tue Feb 5 2019 Remi Collet <remi@remirepo.net> - 2.8.2-3
+- fix FTBFS with zend-validator 2.11, patch from
+ https://github.com/zendframework/zend-file/pull/46
+
* Mon Oct 15 2018 Remi Collet <remi@remirepo.net> - 2.8.2-2
- update to 2.8.2
- drop patch merged upstream