summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-feed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-feed.spec')
-rw-r--r--php-zendframework-zend-feed.spec63
1 files changed, 34 insertions, 29 deletions
diff --git a/php-zendframework-zend-feed.spec b/php-zendframework-zend-feed.spec
index a3e9259..83886ee 100644
--- a/php-zendframework-zend-feed.spec
+++ b/php-zendframework-zend-feed.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 94579e805dd108683209fe14b3b5d4276de3de6e
+%global gh_commit abe88686124d492e0a2a84656f15e5482bfbe030
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-feed
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.0
-Release: 4%{?dist}
+Version: 2.9.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,8 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-feed/pull/50.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -44,23 +42,24 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tidy
-BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-escaper) >= 2.5.2
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "require-dev": {
-# "zendframework/zend-db": "^2.7",
-# "zendframework/zend-cache": "^2.6",
-# "zendframework/zend-http": "^2.5.4",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-validator": "^2.6",
-# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
-# "psr/http-message": "^1.0",
-# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-composer(psr/http-message) >= 1.0
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "psr/http-message": "^1.0.1",
+# "zendframework/zend-cache": "^2.7.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-db": "^2.8.2",
+# "zendframework/zend-http": "^2.7",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-validator": "^2.10.1"
+BuildRequires: php-composer(psr/http-message) < 2
+BuildRequires: php-composer(psr/http-message) >= 1.0.1
+BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.7.2
+BuildRequires: php-composer(%{gh_owner}/zend-db) >= 2.8.2
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.8
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
%else
@@ -68,29 +67,30 @@ BuildRequires: php-composer(psr/http-message) >= 1.0
%endif
BuildRequires: %{phpunit}
# Because of boostraped Db
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.5
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-escaper": "^2.5",
-# "zendframework/zend-stdlib": "^2.7 || ^3.1"
+# "zendframework/zend-escaper": "^2.5.2",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-escaper) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-escaper) >= 2.5.2
Requires: php-composer(%{gh_owner}/zend-escaper) < 3
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
-# "psr/http-message": "PSR-7 ^1.0, if you wish to use Zend\\Feed\\Reader\\Http\\Psr7ResponseDecorator",
+# "psr/http-message": "PSR-7 ^1.0.1, if you wish to use Zend\\Feed\\Reader\\Http\\Psr7ResponseDecorator",
# "zendframework/zend-cache": "Zend\\Cache component, for optionally caching feeds between requests",
# "zendframework/zend-db": "Zend\\Db component, for use with PubSubHubbub",
# "zendframework/zend-http": "Zend\\Http for PubSubHubbub, and optionally for use with Zend\\Feed\\Reader",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component, for easily extending ExtensionManager implementations",
# "zendframework/zend-validator": "Zend\\Validator component, for validating feeds and Atom entries in the Writer subcomponent"
-Requires: php-composer(psr/http-message)
+Requires: php-composer(psr/http-message) < 2
+Requires: php-composer(psr/http-message) >= 1.0.1
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-cache)
Suggests: php-composer(%{gh_owner}/zend-db)
@@ -126,7 +126,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -188,6 +187,12 @@ exit $ret
%changelog
+* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- Update to 2.9.0
+- raise dependency on zend-escaper 2.5.2
+- raise dependency on zend-stdlib 2.7.7
+- raise dependency on psr/http-message 1.0.1
+
* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.8.0-4
- fix FTBFS from Koschei, add patch for PHP 7.2 from
https://github.com/zendframework/zend-feed/pull/50