summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-expressive-zendrouter.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-02 14:08:02 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-02 14:08:02 +0200
commit33e04869a67d82fc4b730492eaa973cc20da2794 (patch)
tree648ed96a7a23c0922a532bae673979c2cdfbf43d /php-zendframework-zend-expressive-zendrouter.spec
parente3cd194f8431e9d0de84051528f6661f6e79c388 (diff)
php-zendframework-zend-expressive-zendrouter: cleanup
Diffstat (limited to 'php-zendframework-zend-expressive-zendrouter.spec')
-rw-r--r--php-zendframework-zend-expressive-zendrouter.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/php-zendframework-zend-expressive-zendrouter.spec b/php-zendframework-zend-expressive-zendrouter.spec
index e5900d1..df88eae 100644
--- a/php-zendframework-zend-expressive-zendrouter.spec
+++ b/php-zendframework-zend-expressive-zendrouter.spec
@@ -22,7 +22,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 1.1.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: zend-mvc router support for %{library}
Group: Development/Libraries
@@ -48,14 +48,18 @@ BuildRequires: php-pcre
# "phpunit/phpunit": "^4.7",
# "squizlabs/php_codesniffer": "^2.3"
BuildRequires: php-composer(phpunit/phpunit) >= 4.7
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+# For dependencies autoloader
+BuildRequires: php-zendframework-zend-loader >= 2.5.1-4
%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "psr/http-message": "^1.0",
-# "zendframework/zend-expressive-router": "^1.2",
-# "zendframework/zend-router": "^3.0",
-# "zendframework/zend-psr7bridge": "^0.2.2"
+# "zendframework/zend-expressive-router": "^1.0",
+# "zendframework/zend-router": "^2.5",
+# "zendframework/zend-psr7bridge": "^0.2.0"
Requires: php(language) >= 5.6
Requires: php-composer(psr/http-message) >= 1.0
Requires: php-composer(psr/http-message) < 2
@@ -69,6 +73,7 @@ Requires: php-pcre
%if ! %{bootstrap}
# Autoloader
Requires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+Requires: php-zendframework-zend-loader >= 2.5.1-4
%endif
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
@@ -88,8 +93,6 @@ https://zendframework.github.io/zend-expressive/features/router/zf2/
mv LICENSE.md LICENSE
-# psr/http-message load by zend-expressive-router
-
%build
# Empty build section, nothing required
@@ -127,7 +130,7 @@ if which php56; then
run=1
fi
if which php71; then
- php70 %{_bindir}/phpunit --verbose || ret=1
+ php71 %{_bindir}/phpunit --verbose || ret=1
run=1
fi
if [ $run -eq 0 ]; then
@@ -154,6 +157,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Jul 2 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-2
+- cleanup and build for ZF2
+
* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 1.1.0-1
- initial package