summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-zendframework-zend-eventmanager.spec29
2 files changed, 19 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index ab9f25a..daa0499 100644
--- a/composer.json
+++ b/composer.json
@@ -35,7 +35,7 @@
"php": "^5.6 || ^7.0"
},
"require-dev": {
- "phpunit/PHPUnit": "^6.0.7 || ^5.7.14",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"athletic/athletic": "^0.1",
"zendframework/zend-stdlib": "^2.7.3 || ^3.0",
"container-interop/container-interop": "^1.1.0",
@@ -53,7 +53,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-eventmanager.spec b/php-zendframework-zend-eventmanager.spec
index 0a717ef..7aa6922 100644
--- a/php-zendframework-zend-eventmanager.spec
+++ b/php-zendframework-zend-eventmanager.spec
@@ -6,7 +6,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9d72db10ceb6e42fb92350c0cb54460da61bd79c
+%global gh_commit a5e2583a211f73604691586b8406ff7296a946dd
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-eventmanager
@@ -19,8 +19,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.2.0
-Release: 3%{?dist}
+Version: 3.2.1
+Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
Group: Development/Libraries
@@ -36,19 +36,22 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^6.0.7 || ^5.7.14",
+# "phpunit/PHPUnit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "athletic/athletic": "^0.1",
# "zendframework/zend-stdlib": "^2.7.3 || ^3.0",
# "container-interop/container-interop": "^1.1.0",
# "zendframework/zend-coding-standard": "~1.0.0"
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.3
BuildRequires: php-composer(container-interop/container-interop) >= 1.1.0
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:4
%else
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
%endif
-BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -60,11 +63,9 @@ Requires: php(language) >= 5.6
# From composer, "suggest": {
# "container-interop/container-interop": "^1.1.0, to use the lazy listeners feature",
# "zendframework/zend-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
-%if 0%{?fedora} >= 21
Suggests: php-composer(container-interop/container-interop)
Suggests: php-composer(%{gh_owner}/zend-stdlib)
%endif
-%endif
# From phpcompatinfo report for version 3.2.0
Requires: php-reflection
Requires: php-spl
@@ -123,10 +124,10 @@ require_once __DIR__ . '/../test/_autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -145,6 +146,10 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1 (no change)
+- switch to phpunit6 or phpunit7
+
* Thu Nov 23 2017 Remi Collet <remi@fedoraproject.org> - 3.2.0-3
- switch from zend-loader to fedora/autoloader