summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-12 10:25:45 +0200
committerRemi Collet <remi@remirepo.net>2017-07-12 10:25:45 +0200
commit698303bc675c9dfab4f9b33e0b57dd5fe63d1602 (patch)
tree3b8b37c733fccf6f2a23427ac118ef58ba2e3cec
parent7ba5c05391087fe1b3d001045f47f145c7d0c333 (diff)
v3.2.0
-rw-r--r--composer.json11
-rw-r--r--php-zendframework-zend-eventmanager.spec46
2 files changed, 27 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index d2dd557..ab9f25a 100644
--- a/composer.json
+++ b/composer.json
@@ -13,8 +13,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "3.1-dev",
- "dev-develop": "3.2-dev"
+ "dev-master": "3.2-dev",
+ "dev-develop": "3.3-dev"
}
},
"autoload": {
@@ -26,13 +26,16 @@
"psr-4": {
"ZendTest\\EventManager\\": "test/",
"ZendBench\\EventManager\\": "benchmarks/"
- }
+ },
+ "files": [
+ "test/_autoload.php"
+ ]
},
"require": {
"php": "^5.6 || ^7.0"
},
"require-dev": {
- "phpunit/PHPUnit": "^5.6",
+ "phpunit/PHPUnit": "^6.0.7 || ^5.7.14",
"athletic/athletic": "^0.1",
"zendframework/zend-stdlib": "^2.7.3 || ^3.0",
"container-interop/container-interop": "^1.1.0",
diff --git a/php-zendframework-zend-eventmanager.spec b/php-zendframework-zend-eventmanager.spec
index 8fabe2b..af42fab 100644
--- a/php-zendframework-zend-eventmanager.spec
+++ b/php-zendframework-zend-eventmanager.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c3bce7b7d47c54040b9ae51bc55491c72513b75d
+%global gh_commit 9d72db10ceb6e42fb92350c0cb54460da61bd79c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-eventmanager
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.0
+Version: 3.2.0
Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -38,14 +37,19 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# From composer, "require-dev": {
-# "phpunit/PHPUnit": "~5.6",
+# "phpunit/PHPUnit": "^6.0.7 || ^5.7.14",
# "athletic/athletic": "^0.1",
# "zendframework/zend-stdlib": "^2.7.3 || ^3.0",
# "container-interop/container-interop": "^1.1.0",
# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 5.6
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.3
BuildRequires: php-composer(container-interop/container-interop) >= 1.1.0
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -95,8 +99,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -114,35 +116,23 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once __DIR__ . '/../test/_autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -151,6 +141,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- Update to 3.2.0
+- use phpunit6 on F26+
+
* Tue Dec 20 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
- update to 3.1.0
- raise dependency on PHP 5.6