summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-01 06:37:49 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-01 06:37:49 +0200
commitefcbb2c3c54ff7d76cb0d86e1c0d543e38de3102 (patch)
tree7ac9d361d532c5b951b3dba4e845a1b988a608df
parentfddff667a79b311f152ec0018a445b7d0e735739 (diff)
php-zendframework-zend-escaper: 2.5.2
-rw-r--r--composer.json35
-rw-r--r--php-zendframework-zend-escaper.spec33
2 files changed, 59 insertions, 9 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2abc628
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "zendframework/zend-escaper",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "escaper"
+ ],
+ "homepage": "https://github.com/zendframework/zend-escaper",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Escaper\\": "src/"
+ }
+ },
+ "require": {
+ "php": ">=5.5"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.5-dev",
+ "dev-develop": "2.6-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Escaper\\": "test/"
+ }
+ },
+ "require-dev": {
+ "fabpot/php-cs-fixer": "1.7.*",
+ "phpunit/PHPUnit": "~4.0"
+ }
+}
diff --git a/php-zendframework-zend-escaper.spec b/php-zendframework-zend-escaper.spec
index 2dfd31d..800447e 100644
--- a/php-zendframework-zend-escaper.spec
+++ b/php-zendframework-zend-escaper.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a4b227d8a477f4e7e9073f8e0a7ae7dbd3104a73
+%global gh_commit 2dcd14b61a72d8b8e27d579c6344e12c26141d4e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-escaper
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
+Version: 2.5.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-ctype
BuildRequires: php-iconv
BuildRequires: php-mbstring
@@ -49,8 +49,8 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23"
-Requires: php(language) >= 5.3.23
+# "php": ">=5.5"
+Requires: php(language) >= 5.5
# From phpcompatinfo report for version 2.5.1
Requires: php-ctype
Requires: php-iconv
@@ -106,11 +106,22 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -130,5 +141,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 1 2016 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP 5.5
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
- initial package