summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-dom.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-dom.spec')
-rw-r--r--php-zendframework-zend-dom.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/php-zendframework-zend-dom.spec b/php-zendframework-zend-dom.spec
index 0405032..c99419c 100644
--- a/php-zendframework-zend-dom.spec
+++ b/php-zendframework-zend-dom.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 181d512f1101fef4534fcf57e1ac7bfba8a2e523
+%global gh_commit a9e145b2b52fe6de5a7a6b0ddb5c773c2c72d59e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-dom
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
-Release: 2%{?dist}
+Version: 2.6.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-dom
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -48,9 +48,9 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23"
-Requires: php(language) >= 5.3.23
-# From phpcompatinfo report for version 2.5.1
+# "php": ">=5.5"
+Requires: php(language) >= 5.5
+# From phpcompatinfo report for version 2.6.0
Requires: php-dom
Requires: php-libxml
Requires: php-pcre
@@ -87,14 +87,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -123,6 +123,10 @@ rm -rf %{buildroot}
%changelog
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise min php version to 5.5
+
* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-2
- fix description