summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-diactoros.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-diactoros.spec')
-rw-r--r--php-zendframework-zend-diactoros.spec34
1 files changed, 27 insertions, 7 deletions
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
index 1677894..99a8019 100644
--- a/php-zendframework-zend-diactoros.spec
+++ b/php-zendframework-zend-diactoros.spec
@@ -12,8 +12,13 @@
%global github_owner zendframework
%global github_name zend-diactoros
-%global github_version 1.8.5
-%global github_commit 3e4edb822c942f37ade0d09579cfbab11e2fee87
+%global github_version 1.8.7
+%global github_commit a85e67b86e9b8520d07e6415fcbcb8391b44a75b
+
+%global github_psr7_owner php-http
+%global github_psr7_name psr7-integration-tests
+%global github_psr7_version 0
+%global github_psr7_commit 5dfefb2da33ca24ae20c971b725c9a6fe7403008
%global composer_vendor zendframework
%global composer_project zend-diactoros
@@ -34,7 +39,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: PSR HTTP Message implementations
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{github_name}/
@@ -42,6 +46,9 @@ URL: https://zendframework.github.io/%{github_name}/
# Run php-zendframework-zend-diactoros-get-source.sh to create full source.
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
+# Temporarily bundled, no release, only used for tests
+Source2: %{github_psr7_owner}-%{github_psr7_name}-%{github_psr7_version}-%{github_psr7_commit}.tar.gz
+Source3: %{github_psr7_owner}-%{github_psr7_name}-get-source.sh
BuildArch: noarch
# Tests
@@ -61,15 +68,18 @@ BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
BuildRequires: %{phpunit}
BuildRequires: php-dom
BuildRequires: php-libxml
-## phpcompatinfo (computed from version 1.6.0)
+## phpcompatinfo (computed from version 1.8.6)
### NOTE: curl, gd, gmp, and shmop are all optional for
### ZendTest\Diactoros\StreamTest::getResourceFor67()
### (test/StreamTest.php) but the first one found wins
### so only curl is chosen as a requirement here.
BuildRequires: php-curl
+BuildRequires: php-dom
BuildRequires: php-json
+BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-reflection
+BuildRequires: php-shmop
BuildRequires: php-spl
%endif
## Autoloader
@@ -85,7 +95,7 @@ Requires: (php-composer(psr/http-message) >= %{psr_http_message_min_ver} wi
Requires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
Requires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
%endif
-# phpcompatinfo (computed from version 1.4.1)
+# phpcompatinfo (computed from version 1.8.6)
Requires: php-json
Requires: php-pcre
Requires: php-spl
@@ -111,8 +121,9 @@ Autoloader: %{phpdir}/Zend/Diactoros/autoload.php
%prep
-%setup -qn %{github_name}-%{github_commit}
+%setup -qn %{github_name}-%{github_commit} -a2
+mv %{github_psr7_name}-%{github_psr7_commit} psr7
mv LICENSE.md LICENSE
@@ -147,6 +158,7 @@ cat <<'BOOTSTRAP' | tee bootstrap.php
require_once '%{buildroot}%{phpdir}/Zend/Diactoros/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Diactoros\\', __DIR__.'/test');
+\Fedora\Autoloader\Autoload::addPsr4('Http\\Psr7Test\\', __DIR__.'/psr7/src');
\Fedora\Autoloader\Dependencies::required(array(
__DIR__.'/test/TestAsset/Functions.php',
@@ -160,7 +172,7 @@ sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhra
: Upstream tests
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php70 php71 php72 php73; do
+for CMDARG in "php %{phpunit}" php71 php72 php73 php74; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit6} --bootstrap bootstrap.php --verbose \
@@ -174,6 +186,7 @@ exit $RETURN_CODE
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -183,6 +196,13 @@ exit $RETURN_CODE
%changelog
+* Fri Aug 30 2019 Remi Collet <remi@remirepo.net> - 1.8.7-1
+- update to 1.8.7
+
+* Thu Sep 6 2018 Remi Collet <remi@remirepo.net> - 1.8.6-1
+- update to 1.8.6
+- bundle php-http/psr7-integration-tests only used for tests
+
* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 1.8.5-1
- update to 1.8.5