summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Iwinski <shawn@iwin.ski>2017-04-08 15:22:34 -0400
committerRemi Collet <remi@remirepo.net>2017-04-10 08:51:42 +0200
commit70d4ce23c734e0f6a72dcd459510153903b862c7 (patch)
treed1bfde945a3ddd43594476cb542bfcce3308d5b6
parent18a38287c6892aeaffcff8db09723f361f4477f2 (diff)
Updated to 1.4.0 (RHBZ #1440332)
(cherry picked from commit 8ca6dedd81dd6c101e63d57ba04063d3e06bb6f3)
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zend-diactoros.spec47
2 files changed, 33 insertions, 22 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..e8c0751
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+/php-zendframework-zend-diactoros-1.1.2-eeedadd333b80bb5d93559e2285047463fe4fe33.tar.gz
+/php-zendframework-zend-diactoros-1.1.3-e2f5c12916c74da384058d0dfbc7fbc0b03d1181.tar.gz
+/php-zendframework-zend-diactoros-1.1.4-3f0ce6c0ba2106e018fb514a9f09dbb91eb6bfd0.tar.gz
+/php-zendframework-zend-diactoros-1.3.3-4d54fde709664562eb63356f0250d527824d05de.tar.gz
+/php-zendframework-zend-diactoros-1.3.7-969ff423d3f201da3ff718a5831bb999bb0669b0.tar.gz
+/php-zendframework-zend-diactoros-1.3.10-83e8d98b9915de76c659ce27d683c02a0f99fa90.tar.gz
+/php-zendframework-zend-diactoros-1.4.0-b03f285a333f51e58c95cce54109a4a9ed691436.tar.gz
diff --git a/php-zendframework-zend-diactoros.spec b/php-zendframework-zend-diactoros.spec
index 1477521..0f4138c 100644
--- a/php-zendframework-zend-diactoros.spec
+++ b/php-zendframework-zend-diactoros.spec
@@ -12,8 +12,8 @@
%global github_owner zendframework
%global github_name zend-diactoros
-%global github_version 1.3.10
-%global github_commit 83e8d98b9915de76c659ce27d683c02a0f99fa90
+%global github_version 1.4.0
+%global github_commit b03f285a333f51e58c95cce54109a4a9ed691436
%global composer_vendor zendframework
%global composer_project zend-diactoros
@@ -43,16 +43,17 @@ URL: https://zendframework.github.io/%{github_name}/
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
## composer.json
-BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
-## phpcompatinfo (computed from version 1.3.10)
+BuildRequires: php-dom
+BuildRequires: php-libxml
+## phpcompatinfo (computed from version 1.4.0)
### NOTE: curl, gd, gmp, and shmop are all optional for
### ZendTest\Diactoros\StreamTest::getResourceFor67()
### (test/StreamTest.php) but the first one found wins
@@ -70,7 +71,7 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: php(language) >= %{php_min_ver}
Requires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
Requires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
-# phpcompatinfo (computed from version 1.3.10)
+# phpcompatinfo (computed from version 1.4.0)
Requires: php-json
Requires: php-pcre
Requires: php-spl
@@ -79,7 +80,7 @@ Requires: php-composer(fedora/autoloader)
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
-Provides: php-composer(psr/http-message-implementation) = 1.0.0
+Provides: php-composer(psr/http-message-implementation) = 1.0
%description
A PHP package containing implementations of the accepted PSR-7 HTTP message
@@ -119,8 +120,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{phpdir}/Zend/Diactoros
cp -rp src/* %{buildroot}%{phpdir}/Zend/Diactoros/
@@ -140,28 +139,25 @@ require_once '%{buildroot}%{phpdir}/Zend/Diactoros/autoload.php';
));
BOOTSTRAP
-: Upstream tests
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
+: Skip test requiring network access
+sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhraseDefaultsAgainstIana/' \
+ -i test/ResponseTest.php
-: Upstream tests with SCLs if available
-SCL_RETURN_CODE=0
-for SCL in %{?rhel:php55} php56 php70 php71; do
- if which $SCL; then
- $SCL %{_bindir}/phpunit --verbose --bootstrap bootstrap.php || SCL_RETURN_CODE=1
+: Upstream tests
+RETURN_CODE=0
+for PHP_EXEC in php %{?rhel:php55} php56 php70 php71; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC %{_bindir}/phpunit --bootstrap bootstrap.php --verbose \
+ || RETURN_CODE=1
fi
done
-exit $SCL_RETURN_CODE
+exit $RETURN_CODE
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -171,6 +167,13 @@ rm -rf %{buildroot}
%changelog
+* Sat Apr 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.0-1
+- Updated to 1.4.0 (RHBZ #1440332)
+
+* Sat Mar 11 2017 Remi Collet <remi@fedoraproject.org> - 1.3.10-2
+- change URL to documentation site
+- simplify documentation
+
* Sun Mar 05 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.10-1
- Updated to 1.3.10 (RHBZ #1411062)
- Test with SCLs if available