summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json11
-rw-r--r--php-zendframework-zend-di3.spec19
2 files changed, 17 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 4cafd69..6dc6dc7 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,7 @@
"issues": "https://github.com/zendframework/zend-di/issues",
"source": "https://github.com/zendframework/zend-di",
"rss": "https://github.com/zendframework/zend-di/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
@@ -24,12 +24,13 @@
},
"require-dev": {
"container-interop/container-interop": "^1.2.0",
- "mikey179/vfsStream": "^1.6",
- "phpunit/phpunit": "^7.3",
+ "mikey179/vfsstream": "^1.6.7",
+ "phpunit/phpunit": "^7.5.18 || ^8.5",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-servicemanager": "^3.0"
},
"conflict": {
+ "phpspec/prophecy": "<1.9.0",
"zendframework/zend-servicemanager-di": "*"
},
"suggest": {
@@ -50,8 +51,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.1-dev",
- "dev-develop": "3.2-dev"
+ "dev-master": "3.1.x-dev",
+ "dev-develop": "3.2.x-dev"
},
"zf": {
"component": "Zend\\Di",
diff --git a/php-zendframework-zend-di3.spec b/php-zendframework-zend-di3.spec
index 68f9147..605d0b0 100644
--- a/php-zendframework-zend-di3.spec
+++ b/php-zendframework-zend-di3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 177e850e1bbd251f8d572ac2952d598741e73be7
+%global gh_commit 8ec4660dad8c1c5a6f9eb91f594fb8a7cb921907
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-di
@@ -21,7 +21,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 3.1.1
+Version: 3.1.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component version %{major}
@@ -44,12 +44,12 @@ BuildRequires: (php-composer(psr/log) >= 1.0 with
BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
# From composer, "require-dev": {
# "container-interop/container-interop": "^1.2.0",
-# "mikey179/vfsStream": "^1.6",
-# "phpunit/phpunit": "^7.3",
+# "mikey179/vfsStream": "^1.6.7",
+# "phpunit/phpunit": "^7.5.18 || ^8.5",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-servicemanager": "^3.0"
BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
+BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6.7 with php-composer(mikey179/vfsStream) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.0 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
# remirepo:8
%else
@@ -62,11 +62,11 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(container-interop/container-interop) < 2
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
BuildRequires: php-composer(mikey179/vfsStream) < 2
-BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
+BuildRequires: php-composer(mikey179/vfsStream) >= 1.6.7
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.0
%endif
-BuildRequires: phpunit7 => 7.3
+BuildRequires: phpunit7 => 7.5.18
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -165,7 +165,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}%{major}/autoload.php';
EOF
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit7 --verbose || ret=1
fi
@@ -186,6 +186,9 @@ exit $ret
%changelog
+* Wed Dec 11 2019 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+
* Thu Feb 28 2019 Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1
- rename to php-zendframework-zend-di3