summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-di.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-di.spec')
-rw-r--r--php-zendframework-zend-di.spec29
1 files changed, 24 insertions, 5 deletions
diff --git a/php-zendframework-zend-di.spec b/php-zendframework-zend-di.spec
index 0799453..0262dd2 100644
--- a/php-zendframework-zend-di.spec
+++ b/php-zendframework-zend-di.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-zendframework-zend-di
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -21,10 +21,9 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.6.1
-Release: 4%{?dist}
+Release: 8%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -37,10 +36,18 @@ BuildRequires: php(language) >= 5.3.23
BuildRequires: php-reflection
BuildRequires: php-pcre
BuildRequires: php-spl
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-code) >= 2.6 with php-autoloader(%{gh_owner}/zend-code) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:6
+%else
BuildRequires: php-composer(container-interop/container-interop) < 2
BuildRequires: php-composer(container-interop/container-interop) >= 1.1
BuildRequires: php-autoloader(%{gh_owner}/zend-code) >= 2.6
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+%endif
# From composer, "require-dev": {
# "fabpot/php-cs-fixer": "1.7.*",
# "phpunit/PHPUnit": "~4.0"
@@ -56,15 +63,23 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 5.3.23
%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-code) >= 2.6 with php-autoloader(%{gh_owner}/zend-code) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:8
+%else
Requires: php-composer(container-interop/container-interop) >= 1.1
Requires: php-composer(container-interop/container-interop) < 2
Requires: php-autoloader(%{gh_owner}/zend-code) >= 2.6
Requires: php-autoloader(%{gh_owner}/zend-code) < 4
Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+%endif
# From composer, "suggest": {
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component"
-%if 0%{?fedora} >= 21
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
%endif
%endif
@@ -126,7 +141,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -138,6 +153,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -146,6 +162,9 @@ exit $ret
%changelog
+* Thu Feb 28 2019 Remi Collet <remi@remirepo.net> - 2.6.1-8
+- use range dependencies
+
* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.6.1-4
- switch from zend-loader to fedora/autoloader