summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commit7f7e245807614630b6c47d5c750b208ad79eaf86 (patch)
treeb3eebfaed338317bc760d67a06fc8dd3fa702cd8
parent8a43f74ebd323407afd71079c39c833dd7b304a0 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-debug.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-zendframework-zend-debug.spec b/php-zendframework-zend-debug.spec
index e05ab0f..af2438e 100644
--- a/php-zendframework-zend-debug.spec
+++ b/php-zendframework-zend-debug.spec
@@ -105,7 +105,12 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif