summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-db.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-db.spec')
-rw-r--r--php-zendframework-zend-db.spec56
1 files changed, 26 insertions, 30 deletions
diff --git a/php-zendframework-zend-db.spec b/php-zendframework-zend-db.spec
index 33eb522..1d69368 100644
--- a/php-zendframework-zend-db.spec
+++ b/php-zendframework-zend-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5926a1a2e7e035546b690cb7d4c11a3c47db2c98
+%global gh_commit b67f2d13c6cf76032db67e58ef1a2983a7b782b6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-db
@@ -19,8 +19,12 @@
%global with_tests 0%{!?_without_tests:1}
%endif
+# TODO: cannot use phpunit6 for now
+# PHP Fatal error: Declaration of ZendTest\Db\IntegrationTestListener::addError(PHPUnit_Framework_Test $test, Exception $e, $time)
+# must be compatible with PHPUnit\Framework\TestListener::addError(PHPUnit\Framework\Test $test, Exception $e, $time) ...
+
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.8.2
+Version: 2.9.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,22 +34,21 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-pdo
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-hydrator": ""^1.1 || ^2.1",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3"
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
BuildRequires: php-composer(%{gh_owner}/zend-hydrator) >= 1.1
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
@@ -55,9 +58,9 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
@@ -101,8 +104,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -120,35 +121,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+require_once dirname(__DIR__) . '/test/autoload.php';
EOF
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -157,6 +145,14 @@ rm -rf %{buildroot}
%changelog
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- Update to 2.9.0
+- raise dependency on PHP 5.6
+
+* Tue Oct 31 2017 Remi Collet <remi@fedoraproject.org> - 2.8.2-4
+- fix FTBFS from Koschei, add patch for PHP 7.2
+ from https://github.com/zendframework/zend-db/pull/276
+
* Wed Aug 10 2016 Remi Collet <remi@fedoraproject.org> - 2.8.2-1
- update to 2.8.2