summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-02 14:46:50 +0100
committerRemi Collet <remi@remirepo.net>2020-01-02 14:46:50 +0100
commitd56a52b27bab5d7a64e70af15218c47678eb46a2 (patch)
tree3dd3693219157a63d10f45bc121277be045e09c6
parente01b0a0d4f2047ec013a3212874d4b00e802638c (diff)
v2.11.0
-rw-r--r--composer.json10
-rw-r--r--php-zendframework-zend-db.spec20
2 files changed, 19 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 5f75f91..2a35647 100644
--- a/composer.json
+++ b/composer.json
@@ -12,7 +12,7 @@
"issues": "https://github.com/zendframework/zend-db/issues",
"source": "https://github.com/zendframework/zend-db",
"rss": "https://github.com/zendframework/zend-db/releases.atom",
- "slack": "https://zendframework-slack.herokuapp.com",
+ "chat": "https://zendframework-slack.herokuapp.com",
"forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
@@ -20,7 +20,7 @@
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.25 || ^6.4.4",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
"zendframework/zend-hydrator": "^1.1 || ^2.1 || ^3.0",
@@ -50,8 +50,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.9-dev",
- "dev-develop": "2.10-dev"
+ "dev-master": "2.11.x-dev",
+ "dev-develop": "2.12.x-dev"
},
"zf": {
"component": "Zend\\Db",
@@ -67,7 +67,7 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always --testsuite \"unit test\"",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "test-integration" : "phpunit --colors=always --testsuite \"integration test\"",
+ "test-integration": "phpunit --colors=always --testsuite \"integration test\"",
"upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-db.spec b/php-zendframework-zend-db.spec
index 9edc285..3e61010 100644
--- a/php-zendframework-zend-db.spec
+++ b/php-zendframework-zend-db.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-db
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 77022f06f6ffd384fa86d22ab8d8bbdb925a1e8e
+%global gh_commit 71626f95f6f9ee326e4be3c34228c1c466300a2c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-db
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.0
+Version: 2.11.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -41,7 +41,7 @@ BuildRequires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.25 || ^6.4.4",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
# "zendframework/zend-hydrator": ""^1.1 || ^2.1 || ^3.0",
@@ -57,7 +57,7 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-hydrator) >= 1.1
BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
%endif
%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.4.4
+BuildRequires: phpunit6 >= 6.5.14
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -144,7 +144,7 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php70 php71 php72 php73; do
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -166,6 +166,14 @@ exit $ret
%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.11.0-2
+- update to 2.11.0
+- drop patch merged upstream
+
+* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 2.10.0-4
+- add patch for PHP 7.4 from
+ https://github.com/zendframework/zend-db/pull/395
+
* Mon Feb 25 2019 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- use range dependencies