summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-25 14:52:57 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-25 14:52:57 +0100
commit814cf6f64c6967531d76f804b2018a153969dd72 (patch)
tree46bfb75b128c650f81694302081f56ab9a33b48d
parentf946fb4c4abfae3444742b7e98cef50f95d3b5b9 (diff)
php-zendframework-zend-crypt: 2.5.2
-rwxr-xr-xmakesrc.sh1
-rw-r--r--php-zendframework-zend-crypt.spec26
2 files changed, 16 insertions, 11 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 24fbf81..e9a1ec5 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,6 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
popd
echo "Archiving..."
diff --git a/php-zendframework-zend-crypt.spec b/php-zendframework-zend-crypt.spec
index 73766dd..c7c0fea 100644
--- a/php-zendframework-zend-crypt.spec
+++ b/php-zendframework-zend-crypt.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 15537e8e438a98923f05c40c45c162342ea8235a
+%global gh_commit b7a5f99f530e7f77762e3eb4011ed1029ffc062f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-crypt
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.1
-Release: 2%{?dist}
+Version: 2.5.2
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.23
+BuildRequires: php(language) >= 5.5
BuildRequires: php-mcrypt
BuildRequires: php-hash
BuildRequires: php-openssl
@@ -54,11 +54,11 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.23",
+# "php": ">=5.5",
# "zendframework/zend-math": "~2.5",
# "zendframework/zend-stdlib": "~2.5",
# "zendframework/zend-servicemanager": "~2.5"
-Requires: php(language) >= 5.3.23
+Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-math) >= 2.5
Requires: php-composer(%{gh_owner}/zend-math) < 3
@@ -118,14 +118,14 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -154,6 +154,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP 5.5
+
* Wed Aug 5 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-2
- fix dependencies