summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-15 11:54:40 +0200
committerRemi Collet <remi@remirepo.net>2019-05-15 11:54:40 +0200
commit140c47283e377571588326eb3e25b3f64217f436 (patch)
tree30497872f25007cfc6cf478b29ae74648cb5fdac
parent87698231b5fc1ef446e84de3744f247800fb58ad (diff)
v3.3.1
-rw-r--r--composer.json35
-rw-r--r--php-zendframework-zend-crypt.spec76
2 files changed, 77 insertions, 34 deletions
diff --git a/composer.json b/composer.json
index 5481614..58dc8d2 100644
--- a/composer.json
+++ b/composer.json
@@ -1,24 +1,30 @@
{
"name": "zendframework/zend-crypt",
- "description": " ",
+ "description": "Strong cryptography tools and password hashing",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"crypt"
],
- "homepage": "https://github.com/zendframework/zend-crypt",
- "minimum-stability": "dev",
- "prefer-stable": true,
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-crypt/",
+ "issues": "https://github.com/zendframework/zend-crypt/issues",
+ "source": "https://github.com/zendframework/zend-crypt",
+ "rss": "https://github.com/zendframework/zend-crypt/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
"require": {
"php": "^5.6 || ^7.0",
"ext-mbstring": "*",
+ "container-interop/container-interop": "^1.2",
"zendframework/zend-math": "^3.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "container-interop/container-interop": "~1.0"
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
- "squizlabs/php_codesniffer": "^2.3.1",
- "phpunit/PHPUnit": "^5.6.7"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"ext-openssl": "Required for most features of Zend\\Crypt"
@@ -29,14 +35,20 @@
}
},
"autoload-dev": {
+ "files": [
+ "test/_autoload.php"
+ ],
"psr-4": {
"ZendTest\\Crypt\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "3.1-dev",
- "dev-develop": "3.2-dev"
+ "dev-master": "3.3.x-dev",
+ "dev-develop": "3.4.x-dev"
}
},
"scripts": {
@@ -44,7 +56,6 @@
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls -v",
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
diff --git a/php-zendframework-zend-crypt.spec b/php-zendframework-zend-crypt.spec
index f9b27de..ceefa1b 100644
--- a/php-zendframework-zend-crypt.spec
+++ b/php-zendframework-zend-crypt.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-crypt
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 514cef5556bac069e36c2cbded40e529b86bb3f2
+%global gh_commit cf23da2731dabdbb916cf888f611fc0f123bd36b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-crypt
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.2.1
-Release: 3%{?dist}
+Version: 3.3.1
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -32,7 +31,7 @@ Source1: makesrc.sh
# remirepo:3
# For test build on all available arch
-#global debug_package %{nil}
+#global debug_package %%{nil}
#global __debug_install_post /bin/true
BuildArch: noarch
# Tests
@@ -43,13 +42,27 @@ BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
-BuildRequires: php-composer(container-interop/container-interop) >= 1.0
# From composer, "require-dev": {
-# "squizlabs/php_codesniffer": "^2.3.1",
-# "phpunit/PHPUnit": "^5.6.7"
-BuildRequires: php-composer(phpunit/phpunit) >= 5.6.7
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 3.0 with php-autoloader(%{gh_owner}/zend-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:10
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
+BuildRequires: php-composer(container-interop/container-interop) >= 1.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -57,18 +70,26 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "ext-mbstring": "*",
+# "container-interop/container-interop": "^1.2",
# "zendframework/zend-math": "^3.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "container-interop/container-interop": "~1.0"
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
Requires: php(language) >= 5.6
Requires: php-mbstring
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-math) >= 3.0
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-math) >= 3.0 with php-autoloader(%{gh_owner}/zend-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:8
+%else
+Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-composer(container-interop/container-interop) >= 1.2
Requires: php-autoloader(%{gh_owner}/zend-math) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-math) >= 3.0
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-composer(container-interop/container-interop) >= 1.0
-Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+%endif
# From composer, "suggest": {
# "ext-openssl": "Required for most features of Zend\\Crypt"
Requires: php-openssl
@@ -79,7 +100,8 @@ Requires: php-composer(fedora/autoloader)
Requires: php-hash
Requires: php-pcre
Requires: php-spl
-%if 0%{?fedora} >= 21
+# remirepo:3
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
Suggests: php-pecl(scrypt)
%endif
@@ -154,9 +176,10 @@ rm test/Key/Derivation/ScryptTest.php
%endif
ret=0
-for cmd in php php56 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
+for cmdarg in "php %{phpunit}" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -175,6 +198,15 @@ exit $ret
%changelog
+* Wed May 15 2019 Remi Collet <remi@remirepo.net> - 3.3.1-1
+- update to 3.3.1
+
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- raise dependency on container-interop/container-interop 1.2
+- switch to phpunit6 or phpunit7
+- use range dependencies on F27+
+
* Mon Dec 4 2017 Remi Collet <remi@remirepo.net> - 3.2.1-3
- switch from zend-loader to fedora/autoloader