summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-07 13:55:52 +0100
committerRemi Collet <remi@remirepo.net>2017-12-07 13:55:52 +0100
commit6b9e043aee1826e49a40ce08934b64f2b2c9b0cf (patch)
treedce34c74f01cab64ca871be73bd9708ae7dec356
parent43968b9857223d7cfb79da7ce2a8b42bda8a04db (diff)
cleanup
-rw-r--r--php-zendframework-zend-console.spec17
1 files changed, 8 insertions, 9 deletions
diff --git a/php-zendframework-zend-console.spec b/php-zendframework-zend-console.spec
index d05d509..5defad2 100644
--- a/php-zendframework-zend-console.spec
+++ b/php-zendframework-zend-console.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -101,8 +100,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -121,18 +118,20 @@ Zend\Loader\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md