summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commit901318e42cc4d449eb1a045b12f7c439948f07bc (patch)
treebf87008dd135d855cfdab2419e22d0e902618857
parent28116bd593ea3bb03e6d0a0afb5a86f76e0d9885 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-config.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-zendframework-zend-config.spec b/php-zendframework-zend-config.spec
index 9318bc4..f082767 100644
--- a/php-zendframework-zend-config.spec
+++ b/php-zendframework-zend-config.spec
@@ -127,7 +127,12 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif