summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--composer.json10
-rw-r--r--php-zendframework-zend-code.spec48
3 files changed, 30 insertions, 35 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index ee15963..fa3ff43 100644
--- a/composer.json
+++ b/composer.json
@@ -13,15 +13,15 @@
}
},
"require": {
- "php": "^5.6 || 7.0.0 - 7.0.4 || ^7.0.6",
+ "php": "^7.1",
"zendframework/zend-eventmanager": "^2.6 || ^3.0"
},
"require-dev": {
"ext-phar": "*",
"doctrine/annotations": "~1.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0",
- "squizlabs/php_codesniffer": "^2.5",
- "phpunit/PHPUnit": "^4.8.21"
+ "phpunit/phpunit": "^6.2.3",
+ "zendframework/zend-coding-standard": "^1.0.0"
},
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
@@ -31,8 +31,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "3.1-dev",
- "dev-develop": "3.2-dev"
+ "dev-master": "3.2-dev",
+ "dev-develop": "3.3-dev"
}
},
"autoload-dev": {
diff --git a/php-zendframework-zend-code.spec b/php-zendframework-zend-code.spec
index 33c6814..e859723 100644
--- a/php-zendframework-zend-code.spec
+++ b/php-zendframework-zend-code.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2899c17f83a7207f2d7f53ec2f421204d3beea27
+%global gh_commit 02944646c109fa53b6b6ab8b5269bb080fcdf5b4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-code
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.0
+Version: 3.2.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,11 +30,10 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.1
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -45,19 +44,19 @@ BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6
# "doctrine/annotations": "~1.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0",
# "zendframework/zend-version": "~2.5",
-# "squizlabs/php_codesniffer": "^2.5",
-# "phpunit/PHPUnit": "^4.8.21"
+# "phpunit/phpunit": "^6.2.3",
+# "zendframework/zend-coding-standard": "^1.0.0"
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.21
+BuildRequires: phpunit6 >= 6.2.3
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.6 || 7.0.0 - 7.0.4 || ^7.0.6",
+# "php": "^7.1",
# "zendframework/zend-eventmanager": "^2.6 || ^3.0""
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.1
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6
Requires: php-composer(%{gh_owner}/zend-eventmanager) < 4
@@ -102,8 +101,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -123,33 +120,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if which php71; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
-# remirepo:2
-fi
+for cmd in php php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -158,6 +141,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- Update to 3.2.0
+- raise dependency on PHP 7.1
+- switch to phpunit6
+
* Tue Oct 25 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
- update to 3.1.0
- raise dependency on PHP 5.6