summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-zendframework-zend-code.spec15
2 files changed, 15 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index cb500dd..0d16521 100644
--- a/composer.json
+++ b/composer.json
@@ -21,11 +21,14 @@
},
"require-dev": {
"ext-phar": "*",
- "doctrine/annotations": "^1.0",
+ "doctrine/annotations": "^1.7",
"phpunit/phpunit": "^7.5.16 || ^8.4",
"zendframework/zend-coding-standard": "^1.0",
"zendframework/zend-stdlib": "^2.7 || ^3.0"
},
+ "conflict": {
+ "phpspec/prophecy": "<1.9.0"
+ },
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
"zendframework/zend-stdlib": "Zend\\Stdlib component"
@@ -46,7 +49,8 @@
"extra": {
"branch-alias": {
"dev-master": "3.4.x-dev",
- "dev-develop": "3.5.x-dev"
+ "dev-develop": "3.5.x-dev",
+ "dev-dev-4.0": "4.0.x-dev"
}
},
"scripts": {
diff --git a/php-zendframework-zend-code.spec b/php-zendframework-zend-code.spec
index beadc65..6d569d7 100644
--- a/php-zendframework-zend-code.spec
+++ b/php-zendframework-zend-code.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-code
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 46feaeecea14161734b56c1ace74f28cb329f194
+%global gh_commit 268040548f92c2bfcba164421c1add2ba43abaaa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-code
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.4.0
+Version: 3.4.1
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -42,18 +42,18 @@ BuildRequires: php-tokenizer
BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
# From composer, "require-dev": {
# "ext-phar": "*",
-# "doctrine/annotations": "^1.0",
+# "doctrine/annotations": "^1.7",
# "phpunit/phpunit": "^7.5.16 || ^8.4,"
# "zendframework/zend-coding-standard": "^1.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-composer(doctrine/annotations) >= 1.7 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
# remirepo:8
%else
BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6
BuildRequires: php-composer(doctrine/annotations) < 2
-BuildRequires: php-composer(doctrine/annotations) >= 1.0
+BuildRequires: php-composer(doctrine/annotations) >= 1.7
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
%endif
@@ -161,6 +161,9 @@ exit $ret
%changelog
+* Wed Dec 11 2019 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- update to 3.4.1
+
* Mon Oct 7 2019 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0
- drop patch merged upstream