summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 18:09:30 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 18:09:30 +0200
commitff7e854a56d8f4c73fc9dd850a3590c6515435c0 (patch)
treef430b8ebe677a0844aef2ad9cd3724508751fbc4
parent21b85d97b054d87da91f10165efed53895bc9196 (diff)
php-zendframework-zend-code: add patch from PR 80
-rw-r--r--php-zendframework-zend-code-pr80.patch21
-rw-r--r--php-zendframework-zend-code.spec11
2 files changed, 31 insertions, 1 deletions
diff --git a/php-zendframework-zend-code-pr80.patch b/php-zendframework-zend-code-pr80.patch
new file mode 100644
index 0000000..5eccb37
--- /dev/null
+++ b/php-zendframework-zend-code-pr80.patch
@@ -0,0 +1,21 @@
+From 8f69e3dfafd3f6e75fa4ffb36fa0b8938a27d9ad Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Wed, 29 Jun 2016 18:02:35 +0200
+Subject: [PATCH] ensure there is only 1 leading NS_SEPARATOR
+
+---
+ src/Generator/ClassGenerator.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Generator/ClassGenerator.php b/src/Generator/ClassGenerator.php
+index 2d382eb..c716e3d 100644
+--- a/src/Generator/ClassGenerator.php
++++ b/src/Generator/ClassGenerator.php
+@@ -1027,6 +1027,6 @@ private function generateShortOrCompleteClassname($fqnClassName)
+ return $className;
+ }
+
+- return '\\' . $fqnClassName;
++ return '\\' . trim($fqnClassName, '\\');
+ }
+ }
diff --git a/php-zendframework-zend-code.spec b/php-zendframework-zend-code.spec
index 9123dc0..e6fdc56 100644
--- a/php-zendframework-zend-code.spec
+++ b/php-zendframework-zend-code.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 3.0.3
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,6 +30,9 @@ URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+# see https://github.com/zendframework/zend-code/pull/80
+Patch0: %{name}-pr80.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
@@ -94,6 +97,8 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
%build
# Empty build section, nothing required
@@ -156,6 +161,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-2
+- add patch for ocramius/proxy-manager
+ https://github.com/zendframework/zend-code/pull/80
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0 for ZendFramework 3