summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-21 05:59:19 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-21 05:59:19 +0200
commitf8b7cc47bf523c45145e304682294035c686903b (patch)
tree9dce5e194bfccf08733084acb260343e9cb2730b
parent0707026100046c8f21cc5a6e76937026186b9264 (diff)
php-zendframework-zend-code: 2.6.3
-rw-r--r--composer.json42
-rw-r--r--php-zendframework-zend-code.spec33
2 files changed, 58 insertions, 17 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..6f1eb86
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,42 @@
+{
+ "name": "zendframework/zend-code",
+ "description": "provides facilities to generate arbitrary code using an object oriented interface",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "code"
+ ],
+ "homepage": "https://github.com/zendframework/zend-code",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Code\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^5.5 || 7.0.0 - 7.0.4 || ^7.0.6",
+ "zendframework/zend-eventmanager": "^2.6 || ^3.0"
+ },
+ "require-dev": {
+ "doctrine/annotations": "~1.0",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0",
+ "fabpot/php-cs-fixer": "1.7.*",
+ "phpunit/PHPUnit": "^4.8.21"
+ },
+ "suggest": {
+ "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
+ "zendframework/zend-stdlib": "Zend\\Stdlib component"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.6-dev",
+ "dev-develop": "2.7-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Code\\": "test/"
+ }
+ }
+}
diff --git a/php-zendframework-zend-code.spec b/php-zendframework-zend-code.spec
index d8bef8d..c6f3fc7 100644
--- a/php-zendframework-zend-code.spec
+++ b/php-zendframework-zend-code.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c4e8f976a772cfb14b47dabd69b5245a423082b4
+%global gh_commit 95033f061b083e16cdee60530ec260d7d628b887
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-code
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.2
+Version: 2.6.3
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -42,21 +42,21 @@ BuildRequires: php-tokenizer
BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6
# From composer, "require-dev": {
# "doctrine/annotations": "~1.0",
-# "zendframework/zend-stdlib": "~2.7",
+# "zendframework/zend-stdlib": "^2.7 || ^3.0",
# "zendframework/zend-version": "~2.5",
# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "phpunit/PHPUnit": "^4.8.21"
BuildRequires: php-composer(doctrine/annotations) >= 1.0
BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
BuildRequires: php-composer(%{gh_owner}/zend-version) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.21
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.5",
-# "zendframework/zend-eventmanager": "^2.6|^3.0"
+# "php": "^5.5 || 7.0.0 - 7.0.4 || ^7.0.6",
+# "zendframework/zend-eventmanager": "^2.6 || ^3.0""
Requires: php(language) >= 5.5
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6
@@ -106,19 +106,15 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
%check
%if %{with_tests}
-# waiting for https://github.com/zendframework/zend-code/pull/5
-sed -s '/Version.php/s:filePath.*$:filePath = "%{php_home}/Zend/Version/Version.php";:' \
- -i test/Reflection/FileReflectionTest.php
-
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
- 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+ 'ZendTest\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
@@ -147,6 +143,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 2.6.3-1
+- update to 2.6.3
+
* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.2-1
- update to 2.6.2
- dependency on doctrine/annotations instrad of doctrine/common
@@ -160,4 +159,4 @@ rm -rf %{buildroot}
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
- initial package
- open https://github.com/zendframework/zend-code/pull/5
- avoid using 'vendor' path \ No newline at end of file
+ avoid using 'vendor' path