summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-11 09:47:16 +0100
committerRemi Collet <remi@remirepo.net>2017-12-11 09:47:16 +0100
commitf2a2a1132989fad0e7131597817601f688c091f3 (patch)
treec2d37c758e330b387aad0bd214e296ffd13be49a
parenta1ec025e6829a8826bd171aa3bc6491940619a9e (diff)
clean
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zend-captcha.spec31
2 files changed, 13 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-zendframework-zend-captcha.spec b/php-zendframework-zend-captcha.spec
index 9f87f50..ac6416a 100644
--- a/php-zendframework-zend-captcha.spec
+++ b/php-zendframework-zend-captcha.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -113,8 +112,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -136,37 +133,19 @@ require_once '%{php_home}/Zend/autoload.php';
require_once '%{php_home}/ZendService/ReCaptcha/autoload.php';
EOF
-# remirepo:15
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php70; then
- php70 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md