summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-22 14:19:57 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-22 14:19:57 +0200
commit694ad90e781e08bef4edac1791f006e4a9f86cf2 (patch)
treeba708cd6740c81386b2a9b4a4ed40e380087cb88
parent9d1e9e7a84edeb8a3ab92a564da19e85f82c8344 (diff)
php-zendframework-zend-captcha: 2.6.0
-rw-r--r--composer.json48
-rw-r--r--php-zendframework-zend-captcha.spec24
2 files changed, 62 insertions, 10 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..ca76073
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,48 @@
+{
+ "name": "zendframework/zend-captcha",
+ "description": " ",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "captcha"
+ ],
+ "homepage": "https://github.com/zendframework/zend-captcha",
+ "autoload": {
+ "psr-4": {
+ "Zend\\Captcha\\": "src/"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-math": "^2.6 || ^3.0",
+ "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ },
+ "require-dev": {
+ "zendframework/zend-session": "^2.6",
+ "zendframework/zend-text": "^2.6",
+ "zendframework/zend-validator": "^2.6",
+ "zendframework/zendservice-recaptcha": "*",
+ "squizlabs/php_codesniffer": "^2.3.1",
+ "phpunit/PHPUnit": "~4.8"
+ },
+ "suggest": {
+ "zendframework/zend-i18n-resources": "Translations of captcha messages",
+ "zendframework/zend-session": "Zend\\Session component",
+ "zendframework/zend-text": "Zend\\Text component",
+ "zendframework/zend-validator": "Zend\\Validator component",
+ "zendframework/zendservice-recaptcha": "ZendService\\ReCaptcha component"
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.6-dev",
+ "dev-develop": "2.7-dev"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Captcha\\": "test/"
+ }
+ }
+}
diff --git a/php-zendframework-zend-captcha.spec b/php-zendframework-zend-captcha.spec
index 8460f28..1de849a 100644
--- a/php-zendframework-zend-captcha.spec
+++ b/php-zendframework-zend-captcha.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 53ddb0e9d0a6d15b7405e2090419f4e11c1174d2
+%global gh_commit 9a1197bc5b8aa4fad104c22f6d9b2a3d4bdda0c6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-captcha
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.4
+Version: 2.6.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -34,7 +34,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-gd
BuildRequires: php-spl
@@ -45,25 +45,25 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# "zendframework/zend-text": "^2.6",
# "zendframework/zend-validator": "^2.6",
# "zendframework/zendservice-recaptcha": "*",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
+# "squizlabs/php_codesniffer": "^2.3.1",
+# "phpunit/PHPUnit": "~4.8"
BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
#BuildRequires: php-composer(%%{gh_owner}/zendservice-recaptcha) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-math": "^2.6",
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-math": "^2.6 || ^3.0",
# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-math) >= 2.6
-Requires: php-composer(%{gh_owner}/zend-math) < 3
+Requires: php-composer(%{gh_owner}/zend-math) < 4
Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
@@ -153,6 +153,10 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 22 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+
* Tue Feb 23 2016 Remi Collet <remi@fedoraproject.org> - 2.5.4-1
- update to 2.5.4
- raise dependency on zend-math >= 2.6