summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-20 15:06:47 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-20 15:06:47 +0100
commit61fde3d8ef75611da9385d62c05181c106caf215 (patch)
tree824b8548066e8c3e5c531b3a8c17f4c9e5ac61e7
parent09fd6f2c0922ee1a125e2ef44fd03bf6a30beab7 (diff)
php-zendframework-zend-captcha: 2.7.0
-rw-r--r--composer.json19
-rw-r--r--php-zendframework-zend-captcha.spec22
2 files changed, 29 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index ca76073..7dcff83 100644
--- a/composer.json
+++ b/composer.json
@@ -21,8 +21,8 @@
"zendframework/zend-session": "^2.6",
"zendframework/zend-text": "^2.6",
"zendframework/zend-validator": "^2.6",
- "zendframework/zendservice-recaptcha": "*",
- "squizlabs/php_codesniffer": "^2.3.1",
+ "zendframework/zendservice-recaptcha": "^3.0",
+ "zendframework/zend-coding-standard": "~1.0.0",
"phpunit/PHPUnit": "~4.8"
},
"suggest": {
@@ -36,13 +36,24 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.6-dev",
- "dev-develop": "2.7-dev"
+ "dev-master": "2.7-dev",
+ "dev-develop": "2.8-dev"
}
},
"autoload-dev": {
"psr-4": {
"ZendTest\\Captcha\\": "test/"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "upload-coverage": "coveralls -v"
}
}
diff --git a/php-zendframework-zend-captcha.spec b/php-zendframework-zend-captcha.spec
index 69e7646..8776284 100644
--- a/php-zendframework-zend-captcha.spec
+++ b/php-zendframework-zend-captcha.spec
@@ -44,13 +44,14 @@ BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
# "zendframework/zend-session": "^2.6",
# "zendframework/zend-text": "^2.6",
# "zendframework/zend-validator": "^2.6",
-# "zendframework/zendservice-recaptcha": "*",
-# "squizlabs/php_codesniffer": "^2.3.1",
+# "zendframework/zendservice-recaptcha": "^3.0",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "phpunit/PHPUnit": "~4.8"
BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-#BuildRequires: php-composer(%%{gh_owner}/zendservice-recaptcha) >= 2.5
+# remirepo:1
+BuildRequires: php-composer(%{gh_owner}/zendservice-recaptcha) >= 3.0
BuildRequires: php-composer(phpunit/phpunit) >= 4.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
@@ -77,7 +78,7 @@ Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
Suggests: php-composer(%{gh_owner}/zend-session)
Suggests: php-composer(%{gh_owner}/zend-text)
Suggests: php-composer(%{gh_owner}/zend-validator)
-#Suggests: php-composer(%%{gh_owner}/zendservice-recaptcha)
+Suggests: php-composer(%{gh_owner}/zendservice-recaptcha)
%endif
%endif
# From phpcompatinfo report for version 2.5.2
@@ -131,25 +132,27 @@ Zend\Loader\AutoloaderFactory::factory(array(
'Zend\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
+# remirepo:1
+require_once '%{php_home}/ZendService/ReCaptcha/autoload.php';
EOF
# remirepo:15
run=0
ret=0
if which php56; then
- php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ php56 %{_bindir}/phpunit || ret=1
run=1
fi
if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ php70 %{_bindir}/phpunit || ret=1
run=1
fi
if which php71; then
- php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ php71 %{_bindir}/phpunit || ret=1
run=1
fi
if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+%{_bindir}/phpunit --verbose
# remirepo:2
fi
exit $ret
@@ -172,6 +175,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Feb 20 2017 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+
* Wed Jun 22 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
- update to 2.6.0
- raise dependency on PHP 5.6