summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-01 11:52:05 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-01 11:52:05 +0100
commit44f84942a4ec4f5305d2b3779b4cebfb649684df (patch)
tree6f10ff70a061b79256652e8e4279af436a4a5387
parente7b314662409b539ae8cb8c67da3739e8519ecd9 (diff)
php-zendframework-zend-captcha: improve test suite
-rw-r--r--php-zendframework-zend-captcha.spec21
1 files changed, 18 insertions, 3 deletions
diff --git a/php-zendframework-zend-captcha.spec b/php-zendframework-zend-captcha.spec
index 883c0bc..f63d40d 100644
--- a/php-zendframework-zend-captcha.spec
+++ b/php-zendframework-zend-captcha.spec
@@ -133,11 +133,26 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
+# remirepo:15
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif