summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-26 13:38:56 +0200
committerRemi Collet <remi@remirepo.net>2018-04-26 13:38:56 +0200
commit18e9f5c0b7f31a6f6d880709d29de30c78101a26 (patch)
tree59f4f0aaa85a5fb9691e5fb345e72f019ca8bb78
parentf2a2a1132989fad0e7131597817601f688c091f3 (diff)
update to 2.8.0zend-loader
raise dependency on zend-math 2.7 raise dependency on zend-stdlib 2.7.7
-rw-r--r--composer.json52
-rw-r--r--php-zendframework-zend-captcha.spec41
2 files changed, 52 insertions, 41 deletions
diff --git a/composer.json b/composer.json
index 7dcff83..eea87fb 100644
--- a/composer.json
+++ b/composer.json
@@ -1,29 +1,32 @@
{
"name": "zendframework/zend-captcha",
- "description": " ",
+ "description": "Generate and validate CAPTCHAs using Figlets, images, ReCaptcha, and more",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"captcha"
],
- "homepage": "https://github.com/zendframework/zend-captcha",
- "autoload": {
- "psr-4": {
- "Zend\\Captcha\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-captcha/",
+ "issues": "https://github.com/zendframework/zend-captcha/issues",
+ "source": "https://github.com/zendframework/zend-captcha",
+ "rss": "https://github.com/zendframework/zend-captcha/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-math": "^2.6 || ^3.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "zendframework/zend-math": "^2.7 || ^3.0",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
- "zendframework/zend-session": "^2.6",
- "zendframework/zend-text": "^2.6",
- "zendframework/zend-validator": "^2.6",
- "zendframework/zendservice-recaptcha": "^3.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"zendframework/zend-coding-standard": "~1.0.0",
- "phpunit/PHPUnit": "~4.8"
+ "zendframework/zend-session": "^2.8",
+ "zendframework/zend-text": "^2.6",
+ "zendframework/zend-validator": "^2.10.1",
+ "zendframework/zendservice-recaptcha": "^3.0"
},
"suggest": {
"zendframework/zend-i18n-resources": "Translations of captcha messages",
@@ -32,12 +35,9 @@
"zendframework/zend-validator": "Zend\\Validator component",
"zendframework/zendservice-recaptcha": "ZendService\\ReCaptcha component"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\Captcha\\": "src/"
}
},
"autoload-dev": {
@@ -45,6 +45,15 @@
"ZendTest\\Captcha\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
@@ -53,7 +62,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-captcha.spec b/php-zendframework-zend-captcha.spec
index ac6416a..3996562 100644
--- a/php-zendframework-zend-captcha.spec
+++ b/php-zendframework-zend-captcha.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-captcha
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2d56293a5ae3e45e7c8ee7030aa8b305768d8014
+%global gh_commit 37e9b6a4f632a9399eecbf2e5e325ad89083f87b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-captcha
@@ -20,11 +20,10 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.1
+Version: 2.8.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
@@ -37,35 +36,34 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-gd
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.7
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "require-dev": {
-# "zendframework/zend-session": "^2.6",
-# "zendframework/zend-text": "^2.6",
-# "zendframework/zend-validator": "^2.6",
-# "zendframework/zendservice-recaptcha": "^3.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
# "zendframework/zend-coding-standard": "~1.0.0",
-# "phpunit/PHPUnit": "~4.8"
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-text": "^2.6",
+# "zendframework/zend-validator": "^2.10.1",
+# "zendframework/zendservice-recaptcha": "^3.0"
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
BuildRequires: php-composer(%{gh_owner}/zend-text) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-# remirepo:1
+BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.10.1
BuildRequires: php-composer(%{gh_owner}/zendservice-recaptcha) >= 3.0
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-math": "^2.6 || ^3.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+# "zendframework/zend-math": "^2.7 || ^3.0",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-composer(%{gh_owner}/zend-math) >= 2.6
Requires: php-composer(%{gh_owner}/zend-math) < 4
-Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-composer(%{gh_owner}/zend-math) >= 2.7
Requires: php-composer(%{gh_owner}/zend-stdlib) < 4
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.7.7
# From composer, "suggest": {
# "zendframework/zend-i18n-resources": "Translations of captcha messages",
# "zendframework/zend-session": "Zend\\Session component",
@@ -154,6 +152,11 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on zend-math 2.7
+- raise dependency on zend-stdlib 2.7.7
+
* Thu Feb 23 2017 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
- update to 2.7.1