summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-26 07:56:49 +0200
committerRemi Collet <remi@remirepo.net>2018-04-26 07:56:49 +0200
commitc3793718530cc4f74236319ca67e8a989e4990cb (patch)
tree85d6769bcdda3796cff307c0d174d4b44304e156
parent3926395cb09a174aff543a993a25c15d16361179 (diff)
update to 2.8.0
raise dependency on PHP 5.6 add dependency on psr/cache add dependency on psr/simple-cache raise dependency on zend-eventmanager 3.2 raise dependency on zend-servicemanager 3.3 raise dependency on zend-stdlib 3.1 use range dependencies (F27+)
-rw-r--r--composer.json82
-rw-r--r--d967c0d39c48a79c3c37ff84d8658240038f4d78.patch345
-rw-r--r--php-zendframework-zend-cache.spec124
3 files changed, 139 insertions, 412 deletions
diff --git a/composer.json b/composer.json
index 77a87b4..7d8f29f 100644
--- a/composer.json
+++ b/composer.json
@@ -1,29 +1,37 @@
{
"name": "zendframework/zend-cache",
- "description": "provides a generic way to cache any data",
+ "description": "Caching implementation with a variety of storage options, as well as codified caching strategies for callbacks, classes, and output",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
- "cache"
+ "zendframework",
+ "zf",
+ "cache",
+ "psr-6",
+ "psr-16"
],
- "homepage": "https://github.com/zendframework/zend-cache",
- "autoload": {
- "psr-4": {
- "Zend\\Cache\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-cache/",
+ "issues": "https://github.com/zendframework/zend-cache/issues",
+ "source": "https://github.com/zendframework/zend-cache",
+ "rss": "https://github.com/zendframework/zend-cache/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-eventmanager": "^2.6.2 || ^3.0"
+ "php": "^5.6 || ^7.0",
+ "psr/cache": "^1.0",
+ "psr/simple-cache": "^1.0",
+ "zendframework/zend-eventmanager": "^2.6.3 || ^3.2",
+ "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
+ "cache/integration-tests": "^0.16",
+ "phpbench/phpbench": "^0.13",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-serializer": "^2.6",
- "zendframework/zend-session": "^2.6.2",
- "phpunit/phpunit": "^4.8",
- "phpbench/phpbench": "^0.10.0",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "zendframework/zend-session": "^2.7.4"
},
"suggest": {
"zendframework/zend-serializer": "Zend\\Serializer component",
@@ -34,27 +42,46 @@
"ext-memcache": "Memcache >= 2.0.0 to use the Memcache storage adapter",
"ext-memcached": "Memcached >= 1.0.0 to use the Memcached storage adapter",
"ext-mongo": "Mongo, to use MongoDb storage adapter",
+ "ext-mongodb": "MongoDB, to use the ExtMongoDb storage adapter",
"ext-redis": "Redis, to use Redis storage adapter",
"ext-wincache": "WinCache, to use the WinCache storage adapter",
"ext-xcache": "XCache, to use the XCache storage adapter",
+ "mongodb/mongodb": "Required for use with the ext-mongodb adapter",
"mongofill/mongofill": "Alternative to ext-mongo - a pure PHP implementation designed as a drop in replacement"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.7-dev",
- "dev-develop": "2.8-dev"
- },
- "zf": {
- "component": "Zend\\Cache",
- "config-provider": "Zend\\Cache\\ConfigProvider"
+ "autoload": {
+ "files": [
+ "autoload/patternPluginManagerPolyfill.php"
+ ],
+ "psr-4": {
+ "Zend\\Cache\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
"ZendTest\\Cache\\": "test/",
"ZendBench\\Cache\\": "benchmark/"
+ },
+ "files": [
+ "test/autoload.php"
+ ]
+ },
+ "config": {
+ "process-timeout": 600,
+ "sort-packages": true
+ },
+ "provide": {
+ "psr/cache-implementation": "1.0",
+ "psr/simple-cache-implementation": "1.0"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ },
+ "zf": {
+ "component": "Zend\\Cache",
+ "config-provider": "Zend\\Cache\\ConfigProvider"
}
},
"scripts": {
@@ -65,7 +92,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/d967c0d39c48a79c3c37ff84d8658240038f4d78.patch b/d967c0d39c48a79c3c37ff84d8658240038f4d78.patch
deleted file mode 100644
index 64a9d41..0000000
--- a/d967c0d39c48a79c3c37ff84d8658240038f4d78.patch
+++ /dev/null
@@ -1,345 +0,0 @@
-Adapted to be usable from EL-6 (patch doesn't support rename)
-
-
-
-From d967c0d39c48a79c3c37ff84d8658240038f4d78 Mon Sep 17 00:00:00 2001
-From: webimpress <contact@webimpress.com>
-Date: Thu, 26 Oct 2017 12:51:36 +0100
-Subject: [PATCH] :fire: Polyfill PatternPluginManager - to allow work with
- Zend SMv2 and v3
-
-Fixes issue with PHP 7.2 signature compatibility.
----
- autoload/patternPluginManagerPolyfill.php | 17 +++++
- composer.json | 7 +-
- composer.lock | 2 +-
- .../PatternPluginManagerTrait.php | 75 +++++++++++++++++++
- .../PatternPluginManagerV2Polyfill.php} | 77 +++----------------
- .../PatternPluginManagerV3Polyfill.php | 87 ++++++++++++++++++++++
- 6 files changed, 197 insertions(+), 68 deletions(-)
- create mode 100644 autoload/patternPluginManagerPolyfill.php
- create mode 100644 src/PatternPluginManager/PatternPluginManagerTrait.php
- rename src/{PatternPluginManager.php => PatternPluginManager/PatternPluginManagerV2Polyfill.php} (51%)
- create mode 100644 src/PatternPluginManager/PatternPluginManagerV3Polyfill.php
-
-diff --git a/autoload/patternPluginManagerPolyfill.php b/autoload/patternPluginManagerPolyfill.php
-new file mode 100644
-index 00000000..4d896fb8
---- /dev/null
-+++ b/autoload/patternPluginManagerPolyfill.php
-@@ -0,0 +1,17 @@
-+<?php
-+/**
-+ * @see https://github.com/zendframework/zend-cache for the canonical source repository
-+ * @copyright Copyright (c) 2017 Zend Technologies USA Inc. (http://www.zend.com)
-+ * @license https://github.com/zendframework/zend-cache/blob/master/LICENSE.md New BSD License
-+ */
-+
-+use Zend\Cache\PatternPluginManager;
-+use Zend\ServiceManager\ServiceManager;
-+
-+call_user_func(function () {
-+ $target = method_exists(ServiceManager::class, 'configure')
-+ ? PatternPluginManager\PatternPluginManagerV3Polyfill::class
-+ : PatternPluginManager\PatternPluginManagerV2Polyfill::class;
-+
-+ class_alias($target, PatternPluginManager::class);
-+});
-diff --git a/src/PatternPluginManager/PatternPluginManagerTrait.php b/src/PatternPluginManager/PatternPluginManagerTrait.php
-new file mode 100644
-index 00000000..8c6f2b27
---- /dev/null
-+++ b/src/PatternPluginManager/PatternPluginManagerTrait.php
-@@ -0,0 +1,75 @@
-+<?php
-+/**
-+ * @see https://github.com/zendframework/zend-cache for the canonical source repository
-+ * @copyright Copyright (c) 2005-2017 Zend Technologies USA Inc. (http://www.zend.com)
-+ * @license https://github.com/zendframework/zend-cache/blob/master/LICENSE.md New BSD License
-+ */
-+
-+namespace Zend\Cache\PatternPluginManager;
-+
-+use Zend\Cache\Exception;
-+use Zend\Cache\Pattern;
-+use Zend\ServiceManager\Exception\InvalidServiceException;
-+
-+/**
-+ * Trait providing common logic between FormElementManager implementations.
-+ *
-+ * Trait does not define properties, as the properties common between the
-+ * two versions are originally defined in their parent class, causing a
-+ * resolution conflict.
-+ */
-+trait PatternPluginManagerTrait
-+{
-+ /**
-+ * Override build to inject options as PatternOptions instance.
-+ *
-+ * {@inheritDoc}
-+ */
-+ public function build($plugin, array $options = null)
-+ {
-+ if (empty($options)) {
-+ return parent::build($plugin);
-+ }
-+
-+ $plugin = parent::build($plugin);
-+ $plugin->setOptions(new Pattern\PatternOptions($options));
-+ return $plugin;
-+ }
-+
-+ /**
-+ * Validate the plugin is of the expected type (v3).
-+ *
-+ * Validates against `$instanceOf`.
-+ *
-+ * @param mixed $instance
-+ * @throws InvalidServiceException
-+ */
-+ public function validate($instance)
-+ {
-+ if (! $instance instanceof $this->instanceOf) {
-+ throw new InvalidServiceException(sprintf(
-+ '%s can only create instances of %s; %s is invalid',
-+ get_class($this),
-+ $this->instanceOf,
-+ (is_object($instance) ? get_class($instance) : gettype($instance))
-+ ));
-+ }
-+ }
-+
-+ /**
-+ * Validate the plugin is of the expected type (v2).
-+ *
-+ * Proxies to `validate()`.
-+ *
-+ * @param mixed $plugin
-+ * @throws Exception\RuntimeException if invalid
-+ */
-+ public function validatePlugin($plugin)
-+ {
-+ try {
-+ $this->validate($plugin);
-+ } catch (InvalidServiceException $e) {
-+ throw new Exception\RuntimeException($e->getMessage(), $e->getCode(), $e);
-+ }
-+ }
-+}
-diff --git a/src/PatternPluginManager.php b/src/PatternPluginManager/PatternPluginManagerV2Polyfill.php
---- a/src/PatternPluginManager/PatternPluginManagerV2Polyfill.php
-+++ b/src/PatternPluginManager/PatternPluginManagerV2Polyfill.php
-@@ -1,27 +1,27 @@
- <?php
- /**
-- * Zend Framework (http://framework.zend.com/)
-- *
-- * @link http://github.com/zendframework/zf2 for the canonical source repository
-- * @copyright Copyright (c) 2005-2016 Zend Technologies USA Inc. (http://www.zend.com)
-- * @license http://framework.zend.com/license/new-bsd New BSD License
-+ * @see https://github.com/zendframework/zend-cache for the canonical source repository
-+ * @copyright Copyright (c) 2017 Zend Technologies USA Inc. (http://www.zend.com)
-+ * @license https://github.com/zendframework/zend-cache/blob/master/LICENSE.md New BSD License
- */
-
--namespace Zend\Cache;
-+namespace Zend\Cache\PatternPluginManager;
-
-+use Zend\Cache\Pattern;
- use Zend\ServiceManager\AbstractPluginManager;
- use Zend\ServiceManager\Factory\InvokableFactory;
--use Zend\ServiceManager\Exception\InvalidServiceException;
-
- /**
-- * Plugin manager implementation for cache pattern adapters
-+ * zend-servicemanager v2-compatible plugin manager implementation for cache pattern adapters.
- *
- * Enforces that retrieved adapters are instances of
- * Pattern\PatternInterface. Additionally, it registers a number of default
- * patterns available.
- */
--class PatternPluginManager extends AbstractPluginManager
-+class PatternPluginManagerV2Polyfill extends AbstractPluginManager
- {
-+ use PatternPluginManagerTrait;
-+
- protected $aliases = [
- 'callback' => Pattern\CallbackCache::class,
- 'Callback' => Pattern\CallbackCache::class,
-@@ -53,14 +53,14 @@ class PatternPluginManager extends AbstractPluginManager
- /**
- * Don't share by default
- *
-- * @var boolean
-+ * @var bool
- */
- protected $shareByDefault = false;
-
- /**
- * Don't share by default
- *
-- * @var boolean
-+ * @var bool
- */
- protected $sharedByDefault = false;
-
-@@ -74,7 +74,7 @@ class PatternPluginManager extends AbstractPluginManager
- *
- * {@inheritDoc}
- */
-- public function get($plugin, array $options = [], $usePeeringServiceManagers = true)
-+ public function get($plugin, $options = [], $usePeeringServiceManagers = true)
- {
- if (empty($options)) {
- return parent::get($plugin, [], $usePeeringServiceManagers);
-@@ -84,57 +84,4 @@ public function get($plugin, array $options = [], $usePeeringServiceManagers = t
- $plugin->setOptions(new Pattern\PatternOptions($options));
- return $plugin;
- }
--
-- /**
-- * Override build to inject options as PatternOptions instance.
-- *
-- * {@inheritDoc}
-- */
-- public function build($plugin, array $options = null)
-- {
-- if (empty($options)) {
-- return parent::build($plugin);
-- }
--
-- $plugin = parent::build($plugin);
-- $plugin->setOptions(new Pattern\PatternOptions($options));
-- return $plugin;
-- }
--
-- /**
-- * Validate the plugin is of the expected type (v3).
-- *
-- * Validates against `$instanceOf`.
-- *
-- * @param mixed $instance
-- * @throws InvalidServiceException
-- */
-- public function validate($instance)
-- {
-- if (! $instance instanceof $this->instanceOf) {
-- throw new InvalidServiceException(sprintf(
-- '%s can only create instances of %s; %s is invalid',
-- get_class($this),
-- $this->instanceOf,
-- (is_object($instance) ? get_class($instance) : gettype($instance))
-- ));
-- }
-- }
--
-- /**
-- * Validate the plugin is of the expected type (v2).
-- *
-- * Proxies to `validate()`.
-- *
-- * @param mixed $plugin
-- * @throws Exception\RuntimeException if invalid
-- */
-- public function validatePlugin($plugin)
-- {
-- try {
-- $this->validate($plugin);
-- } catch (InvalidServiceException $e) {
-- throw new Exception\RuntimeException($e->getMessage(), $e->getCode(), $e);
-- }
-- }
- }
-diff --git a/src/PatternPluginManager/PatternPluginManagerV3Polyfill.php b/src/PatternPluginManager/PatternPluginManagerV3Polyfill.php
-new file mode 100644
-index 00000000..c00ef1d5
---- /dev/null
-+++ b/src/PatternPluginManager/PatternPluginManagerV3Polyfill.php
-@@ -0,0 +1,87 @@
-+<?php
-+/**
-+ * @see https://github.com/zendframework/zend-cache for the canonical source repository
-+ * @copyright Copyright (c) 2017 Zend Technologies USA Inc. (http://www.zend.com)
-+ * @license https://github.com/zendframework/zend-cache/blob/master/LICENSE.md New BSD License
-+ */
-+
-+namespace Zend\Cache\PatternPluginManager;
-+
-+use Zend\Cache\Pattern;
-+use Zend\ServiceManager\AbstractPluginManager;
-+use Zend\ServiceManager\Factory\InvokableFactory;
-+
-+/**
-+ * zend-servicemanager v3-compatible plugin manager implementation for cache pattern adapters.
-+ *
-+ * Enforces that retrieved adapters are instances of
-+ * Pattern\PatternInterface. Additionally, it registers a number of default
-+ * patterns available.
-+ */
-+class PatternPluginManagerV3Polyfill extends AbstractPluginManager
-+{
-+ use PatternPluginManagerTrait;
-+
-+ protected $aliases = [
-+ 'callback' => Pattern\CallbackCache::class,
-+ 'Callback' => Pattern\CallbackCache::class,
-+ 'capture' => Pattern\CaptureCache::class,
-+ 'Capture' => Pattern\CaptureCache::class,
-+ 'class' => Pattern\ClassCache::class,
-+ 'Class' => Pattern\ClassCache::class,
-+ 'object' => Pattern\ObjectCache::class,
-+ 'Object' => Pattern\ObjectCache::class,
-+ 'output' => Pattern\OutputCache::class,
-+ 'Output' => Pattern\OutputCache::class,
-+ ];
-+
-+ protected $factories = [
-+ Pattern\CallbackCache::class => InvokableFactory::class,
-+ Pattern\CaptureCache::class => InvokableFactory::class,
-+ Pattern\ClassCache::class => InvokableFactory::class,
-+ Pattern\ObjectCache::class => InvokableFactory::class,
-+ Pattern\OutputCache::class => InvokableFactory::class,
-+
-+ // v2 normalized FQCNs
-+ 'zendcachepatterncallbackcache' => InvokableFactory::class,
-+ 'zendcachepatterncapturecache' => InvokableFactory::class,
-+ 'zendcachepatternclasscache' => InvokableFactory::class,
-+ 'zendcachepatternobjectcache' => InvokableFactory::class,
-+ 'zendcachepatternoutputcache' => InvokableFactory::class,
-+ ];
-+
-+ /**
-+ * Don't share by default
-+ *
-+ * @var bool
-+ */
-+ protected $shareByDefault = false;
-+
-+ /**
-+ * Don't share by default
-+ *
-+ * @var bool
-+ */
-+ protected $sharedByDefault = false;
-+
-+ /**
-+ * @var string
-+ */
-+ protected $instanceOf = Pattern\PatternInterface::class;
-+
-+ /**
-+ * Override get to inject options as PatternOptions instance.
-+ *
-+ * {@inheritDoc}
-+ */
-+ public function get($plugin, array $options = null, $usePeeringServiceManagers = true)
-+ {
-+ if (empty($options)) {
-+ return parent::get($plugin, null, $usePeeringServiceManagers);
-+ }
-+
-+ $plugin = parent::get($plugin, null, $usePeeringServiceManagers);
-+ $plugin->setOptions(new Pattern\PatternOptions($options));
-+ return $plugin;
-+ }
-+}
diff --git a/php-zendframework-zend-cache.spec b/php-zendframework-zend-cache.spec
index 0116b98..76117fc 100644
--- a/php-zendframework-zend-cache.spec
+++ b/php-zendframework-zend-cache.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-cache
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c98331b96d3b9d9b24cf32d02660602edb34d039
+%global gh_commit e57717839e040227133f1df8d158a05f85a7be6c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-cache
@@ -20,56 +20,91 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.7.2
-Release: 6%{?dist}
+Version: 2.8.0
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
-Group: Development/Libraries
License: BSD
URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://github.com/zendframework/zend-cache/commit/d967c0d39c48a79c3c37ff84d8658240038f4d78.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-reflection
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+BuildRequires: (php-composer(psr/simple-cache) >= 1.0 with php-composer(psr/simple-cache) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
# From composer, "require-dev": {
+# "cache/integration-tests": "^0.16",
+# "phpbench/phpbench": "^0.13",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-serializer": "^2.6",
-# "zendframework/zend-session": "^2.6.2",
-# "phpunit/phpunit": "^4.8",
-# "phpbench/phpbench": "^0.10.0",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "zendframework/zend-session": "^2.7.4"
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:12
+%else
+BuildRequires: php-composer(psr/cache) < 2
+BuildRequires: php-composer(psr/cache) >= 1.0
+BuildRequires: php-composer(psr/simple-cache) < 2
+BuildRequires: php-composer(psr/simple-cache) >= 1.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 3.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.3
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+BuildRequires: php-cache-integration-tests >= 0.16
BuildRequires: php-composer(%{gh_owner}/zend-serializer) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.7.4
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "psr/cache": "^1.0",
+# "psr/simple-cache": "^1.0",
+# "zendframework/zend-eventmanager": "^2.6.3 || ^3.2",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+Requires: (php-composer(psr/simple-cache) >= 1.0 with php-composer(psr/simple-cache) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:12
+%else
+Requires: php-composer(psr/cache) < 2
+Requires: php-composer(psr/cache) >= 1.0
+Requires: php-composer(psr/simple-cache) < 2
+Requires: php-composer(psr/simple-cache) >= 1.0
Requires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 3.2
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 3.3
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1
+%endif
# From composer, "suggest": {
# "zendframework/zend-serializer": "Zend\\Serializer component",
# "zendframework/zend-session": "Zend\\Session component",
@@ -80,23 +115,23 @@ Requires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
# "ext-memcache": "Memcache >= 2.0.0 to use the Memcache storage adapter",
# "ext-memcached": "Memcached >= 1.0.0 to use the Memcached storage adapter",
# "ext-mongo": "Mongo, to use MongoDb storage adapter",
+# "ext-mongodb": "MongoDB, to use the ExtMongoDb storage adapter",
# "ext-redis": "Redis, to use Redis storage adapter",
# "ext-wincache": "WinCache, to use the WinCache storage adapter",
# "ext-xcache": "XCache, to use the XCache storage adapter",
+# "mongodb/mongodb": "Required for use with the ext-mongodb adapter",
# "mongofill/mongofill": "Alternative to ext-mongo - a pure PHP implementation designed as a drop in replacement"
-%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-serializer)
Suggests: php-composer(%{gh_owner}/zend-session)
Suggests: php-pecl(apcu)
Suggests: php-dba
Suggests: php-pecl(memcache)
Suggests: php-pecl(memcached)
-Suggests: php-pecl(mongo)
+Suggests: php-pecl(mongodb)
Suggests: php-pecl(redis)
-Suggests: php-xcache
+Suggests: php-composer(mongodb/mongodb)
%endif
-%endif
-# From phpcompatinfo report for version 2.5.2
+# From phpcompatinfo report for version 2.8.0
Requires: php-reflection
Requires: php-date
Requires: php-pcre
@@ -113,6 +148,8 @@ Provides: php-ZendFramework2-%{library}-apc = %{version}
Provides: php-ZendFramework2-%{library}-memcached = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(psr/cache-implementation) = 1.0
+Provides: php-composer(psr/simple-cache-implementation) = 1.0
%description
@@ -126,10 +163,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-# EL-6 patch don't allow rename
-mkdir src/PatternPluginManager
-mv src/PatternPluginManager.php src/PatternPluginManager/PatternPluginManagerV2Polyfill.php
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -174,6 +207,7 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
# For BR without new autoloader
\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Cache/IntegrationTests/autoload.php',
'%{php_home}/Zend/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
@@ -185,9 +219,10 @@ sed -e '/unlinkDelay/s/5000/50000/' \
-i test/Storage/Adapter/FilesystemTest.php
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -206,6 +241,17 @@ exit $ret
%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- update to 2.8.0
+- raise dependency on PHP 5.6
+- add dependency on psr/cache
+- add dependency on psr/simple-cache
+- raise dependency on zend-eventmanager 3.2
+- raise dependency on zend-servicemanager 3.3
+- raise dependency on zend-stdlib 3.1
+- use range dependencies (F27+)
+- switch to phpunit6 or phpunit7
+
* Fri Nov 24 2017 Remi Collet <remi@remirepo.net> - 2.7.2-6
- switch from zend-loader to fedora/autoloader