summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-16 10:23:22 +0200
committerRemi Collet <remi@remirepo.net>2018-04-16 10:23:22 +0200
commit8b87e441e6e411cc8628b0493dcea009430e85d1 (patch)
treecc279650b2a438f077d9f942346f524deaf05614
parentceee9fdcb164c23401168caa4acec017724572e5 (diff)
update to 2.6.0
raise dependency on PHP 5.6 raise dependency on zend-stdlib 3.1 use phpunit7
-rw-r--r--composer.json70
-rw-r--r--php-zendframework-zend-authentication.spec72
2 files changed, 88 insertions, 54 deletions
diff --git a/composer.json b/composer.json
index 63a24ce..a6804e5 100644
--- a/composer.json
+++ b/composer.json
@@ -3,50 +3,72 @@
"description": "provides an API for authentication and includes concrete authentication adapters for common use case scenarios",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"authentication"
],
- "homepage": "https://github.com/zendframework/zend-authentication",
- "autoload": {
- "psr-4": {
- "Zend\\Authentication\\": "src/"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-authentication/",
+ "issues": "https://github.com/zendframework/zend-authentication/issues",
+ "source": "https://github.com/zendframework/zend-authentication",
+ "rss": "https://github.com/zendframework/zend-authentication/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
- "php": "^5.5 || ^7.0",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
},
"require-dev": {
- "zendframework/zend-db": "^2.7",
- "zendframework/zend-crypt": "^2.6",
- "zendframework/zend-http": "^2.5.4",
- "zendframework/zend-ldap": "^2.6",
- "zendframework/zend-session": "^2.6.2",
- "zendframework/zend-validator": "^2.6",
- "zendframework/zend-uri": "^2.5",
- "fabpot/php-cs-fixer": "1.7.*",
- "phpunit/PHPUnit": "~4.0"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-crypt": "^2.6 || ^3.2.1",
+ "zendframework/zend-db": "^2.8.2",
+ "zendframework/zend-http": "^2.7",
+ "zendframework/zend-ldap": "^2.8",
+ "zendframework/zend-session": "^2.8",
+ "zendframework/zend-uri": "^2.5.2",
+ "zendframework/zend-validator": "^2.10.1"
},
"suggest": {
- "zendframework/zend-db": "Zend\\Db component",
"zendframework/zend-crypt": "Zend\\Crypt component",
+ "zendframework/zend-db": "Zend\\Db component",
"zendframework/zend-http": "Zend\\Http component",
"zendframework/zend-ldap": "Zend\\Ldap component",
"zendframework/zend-session": "Zend\\Session component",
"zendframework/zend-uri": "Zend\\Uri component",
"zendframework/zend-validator": "Zend\\Validator component"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
- "extra": {
- "branch-alias": {
- "dev-master": "2.5-dev",
- "dev-develop": "2.6-dev"
+ "autoload": {
+ "psr-4": {
+ "Zend\\Authentication\\": "src/"
}
},
"autoload-dev": {
+ "files": [
+ "test/autoload.php"
+ ],
"psr-4": {
"ZendTest\\Authentication\\": "test/"
}
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.6.x-dev",
+ "dev-develop": "2.7.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-authentication.spec b/php-zendframework-zend-authentication.spec
index 06a4215..c89991b 100644
--- a/php-zendframework-zend-authentication.spec
+++ b/php-zendframework-zend-authentication.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1422dec160eb769c719cad2229847fcbf20a1405
+%global gh_commit ebc9464c11a5203e5256439f1079a7d6efe89eec
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-authentication
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.5.3
-Release: 4%{?dist}
+Version: 2.6.0
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -33,41 +33,48 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-hash
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1
# From composer, "require-dev": {
-# "zendframework/zend-db": "^2.7",
-# "zendframework/zend-crypt": "^2.6",
-# "zendframework/zend-http": "^2.5.4",
-# "zendframework/zend-ldap": "^2.6",
-# "zendframework/zend-session": "^2.6.2",
-# "zendframework/zend-validator": "^2.6",
-# "zendframework/zend-uri": "^2.5",
-# "fabpot/php-cs-fixer": "1.7.*",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.7
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-crypt": "^2.6 || ^3.2.1",
+# "zendframework/zend-db": "^2.8.2",
+# "zendframework/zend-http": "^2.7",
+# "zendframework/zend-ldap": "^2.8",
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-uri": "^2.5.2",
+# "zendframework/zend-validator": "^2.10.1"
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.8.2
BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
-BuildRequires: php-autoloader(%{gh_owner}/zend-ldap) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.6.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-ldap) >= 2.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+# remirepo:3
+%else
+%global phpunit %{_bindir}/phpunit6
+%endif
+BuildRequires: %{phpunit}
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-Requires: php(language) >= 5.5
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1"
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.1
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
# From composer, "suggest": {
# "zendframework/zend-db": "Zend\\Db component",
@@ -77,7 +84,6 @@ Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
# "zendframework/zend-session": "Zend\\Session component",
# "zendframework/zend-uri": "Zend\\Uri component",
# "zendframework/zend-validator": "Zend\\Validator component"
-%if 0%{?fedora} >= 21
Suggests: php-autoloader(%{gh_owner}/zend-db)
Suggests: php-autoloader(%{gh_owner}/zend-crypt)
Suggests: php-autoloader(%{gh_owner}/zend-http)
@@ -86,7 +92,6 @@ Suggests: php-autoloader(%{gh_owner}/zend-session)
Suggests: php-autoloader(%{gh_owner}/zend-uri)
Suggests: php-autoloader(%{gh_owner}/zend-validator)
%endif
-%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.5.2
@@ -149,9 +154,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} || ret=1
fi
done
exit $ret
@@ -169,6 +175,12 @@ exit $ret
%changelog
+* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.6.0-2
+- update to 2.6.0
+- raise dependency on PHP 5.6
+- raise dependency on zend-stdlib 3.1
+- use phpunit7
+
* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.5.3-4
- switch from zend-loader to fedora/autoloader