summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-12 12:37:40 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-12 12:37:40 +0200
commitdf1966732ff0333d0b8330d9e650245cdc2a8d05 (patch)
tree69ec0e304fb8ac25d663acef5d0ac4955478e7ef
parent6889e63d4f9671f501621e8aba1d9703b11d91bd (diff)
php-ZendFramework2: 2.4.7
-rw-r--r--ZendFramework-icu54.patch24
-rw-r--r--php-ZendFramework2.spec66
2 files changed, 26 insertions, 64 deletions
diff --git a/ZendFramework-icu54.patch b/ZendFramework-icu54.patch
deleted file mode 100644
index d52eaec..0000000
--- a/ZendFramework-icu54.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 04333cd50b2a2c3f230d543472734f0b96ca5685 Mon Sep 17 00:00:00 2001
-From: Mark Garrett <mark@moderndeveloperllc.com>
-Date: Tue, 17 Feb 2015 09:58:07 -0600
-Subject: [PATCH] Fix for #7219 - Validation failure fr-CH in
- testValidationFailures due to change in CLDR 26. Just removed that one
- instance that is actually valid now.
-
----
- tests/ZendTest/I18n/Validator/FloatTest.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/ZendTest/I18n/Validator/FloatTest.php b/tests/ZendTest/I18n/Validator/FloatTest.php
-index 0073c30..ec27528 100644
---- a/tests/ZendTest/I18n/Validator/FloatTest.php
-+++ b/tests/ZendTest/I18n/Validator/FloatTest.php
-@@ -166,7 +166,7 @@ public function validationFailureProvider()
- 'ar' => array('10.1', '66notflot.6'),
- 'ru' => array('10.1', '66notflot.6', '2,000.00', '2 00'),
- 'en' => array('10,1', '66notflot.6', '2.000,00', '2 000', '2,00'),
-- 'fr-CH' => array('10,1', '66notflot.6', '2,000.00', '2 000', "2'00")
-+ 'fr-CH' => array('10,1', '66notflot.6', '2,000.00', "2'00")
- );
-
- //Loop locales and examples for a more thorough set of "true" test data
diff --git a/php-ZendFramework2.spec b/php-ZendFramework2.spec
index 75afde4..5f4cc2b 100644
--- a/php-ZendFramework2.spec
+++ b/php-ZendFramework2.spec
@@ -17,7 +17,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-ZendFramework2
-Version: 2.3.9
+Version: 2.4.7
Release: 1%{?dist}
Summary: Zend Framework 2
@@ -30,9 +30,8 @@ Source0: https://packages.zendframework.com/releases/ZendFramework-%{version}/
# git checkout release-2.3.9
# tar czf ../ZendFramework-tests-2.3.9.tgz tests
Source1: ZendFramework-tests-%{version}.tgz
-
-# See https://github.com/zendframework/zf2/issues/7219
-Patch0: ZendFramework-icu54.patch
+# Autoloader
+Source2: ZendFramework-autoload.php
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -47,6 +46,7 @@ BuildRequires: php-bz2
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
+BuildRequires: php-dba
BuildRequires: php-dom
BuildRequires: php-fileinfo
BuildRequires: php-filter
@@ -276,6 +276,7 @@ Optional:
* DBA (php-dba)
* Memcache (php-pecl-memcache)
* Memcached (php-pecl-memcached)
+* Mongo (php-pecl-mongo)
* Redis (php-pecl-redis)
* XCache (php-xcache)
@@ -1851,8 +1852,6 @@ If the XML document uses ENTITY the library throw an Exception.
%prep
%setup -q -n ZendFramework-%{version} -a 1
-%patch0 -p1
-
%build
# Empty build section, nothing required
@@ -1862,6 +1861,8 @@ If the XML document uses ENTITY the library throw an Exception.
mkdir -p %{buildroot}%{_datadir}/php
cp -rp library/* %{buildroot}%{_datadir}/php
+install -pm 644 %{SOURCE2} %{buildroot}%{_datadir}/php/Zend/autoload.php
+
# Symlink package docs to common sub-package docs
mkdir -p %{buildroot}%{_docdir}
%if "%{_pkgdocdir}" == "%{_docdir}/%{name}"
@@ -1874,44 +1875,24 @@ ln -s %{name}-common-%{version} %{buildroot}%{_pkgdocdir}
%check
%if %{with_tests}
cd tests
-# Create autoloader
-cat > _autoload.php <<'AUTOLOADER'
+: Create autoloader for test suite
+cat <<'AUTOLOADER' | tee _autoload.php
<?php
-require_once 'Symfony/Component/ClassLoader/UniversalClassLoader.php';
-
-use Symfony\Component\ClassLoader\UniversalClassLoader;
-$loader = new UniversalClassLoader();
-$loader->registerNamespace('Zend', __DIR__.'/../library');
-$loader->registerNamespace('ZendTest', __DIR__);
-$loader->registerNamespace('org\\bovigo\\vfs', '/usr/share/php');
-$loader->registerNamespace('RandomLib', '/usr/share/php');
-$loader->registerNamespace('SecurityLib', '/usr/share/php');
-$loader->useIncludePath(true);
-$loader->register();
+require_once '%{buildroot}%{_datadir}/php/Zend/autoload.php';
+
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\\Loader\\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendTest' => __DIR__ . '/ZendTest',
+))));
AUTOLOADER
-sed -e 's/ colors="true"//' \
- phpunit.xml.dist >phpunit.xml
-
-# ignore these for now
-rm -r ZendTest/Cache
-rm ZendTest/Console/RequestTest.php
-rm -r ZendTest/Debug
-rm ZendTest/File/Transfer/Adapter/HttpTest.php
-rm ZendTest/Form/View/Helper/FormDateTimeSelectTest.php
-# This test requires internet conectivity
-rm ZendTest/Version/VersionTest.php
-# Date format with microsecond in PHP 5.6
-rm ZendTest/Ldap/Converter/ConverterTest.php
-# Need mongodb server
-rm ZendTest/Session/SaveHandler/MongoDBTest.php
-# Strangly fail, lack of date.timezone
-rm ZendTest/Session/SessionManagerTest.php
-# Need investigation
-rm ZendTest/Db/Adapter/Platform/SqliteTest.php
+: ignore these for now
+rm ZendTest/Mvc/Controller/Plugin/FilePostRedirectGetTest.php
+
%if 0%{?rhel} == 5
-rm ZendTest/Feed/PubSubHubbub/Model/SubscriptionTest.php
-rm ZendTest/Session/SaveHandler/DbTableGatewayTest.php
+rm ZendTest/Feed/PubSubHubbub/Model/SubscriptionTest.php
+rm ZendTest/Session/SaveHandler/DbTableGatewayTest.php
%endif
RET=0
@@ -2222,6 +2203,7 @@ exit $RET
%doc library/Zend/Loader/*.md
%doc library/Zend/Loader/composer.json
+%{_datadir}/php/Zend/autoload.php
%{_datadir}/php/Zend/Loader
%exclude %{_datadir}/php/Zend/Loader/*.md
%exclude %{_datadir}/php/Zend/Loader/composer.json
@@ -2550,6 +2532,10 @@ exit $RET
# ##############################################################################
%changelog
+* Wed Aug 12 2015 Remi Collet <remi@fedoraproject.org> - 2.4.7-1
+- Update to 2.4.7
+- add autoloader in php-ZendFramework2-Loader
+
* Thu May 21 2015 Remi Collet <remi@fedoraproject.org> - 2.3.9-1
- Update to 2.3.9