summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-14 13:19:18 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-14 13:19:18 +0200
commit244b37de102ad170f56b391e067ddef6239634b5 (patch)
tree1e6207c2576509c1e4ac944f067e61c6d629e12a
parentfefdb1fbfd9933f9344721d5f24de0ad927fe5c4 (diff)
php-ZendFramework: 1.12.18
-rw-r--r--composer.json37
-rw-r--r--php-ZendFramework.spec14
2 files changed, 47 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..eb84b09
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,37 @@
+{
+ "name": "zendframework/zendframework1",
+ "description": "Zend Framework 1",
+ "type": "library",
+ "keywords": [
+ "framework",
+ "zf1"
+ ],
+ "homepage": "http://framework.zend.com/",
+ "license": "BSD-3-Clause",
+ "require": {
+ "php": ">=5.2.11"
+ },
+ "autoload": {
+ "psr-0": {
+ "Zend_": "library/"
+ }
+ },
+ "include-path": [
+ "library/"
+ ],
+ "config": {
+ "bin-dir": "bin"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.12.x-dev"
+ }
+ },
+ "require-dev": {
+ "phpunit/phpunit": "3.7.*",
+ "phpunit/dbunit": "1.3.*"
+ },
+ "archive": {
+ "exclude": ["/demos", "/documentation", "/tests"]
+ }
+}
diff --git a/php-ZendFramework.spec b/php-ZendFramework.spec
index bf9cc06..f03139a 100644
--- a/php-ZendFramework.spec
+++ b/php-ZendFramework.spec
@@ -9,13 +9,13 @@
#
%global php_name ZendFramework
-%global with_extras 0
-%global with_firebird 0
+%global with_extras 1
+%global with_firebird 1
#define posttag .PL1
Summary: Leading open-source PHP framework
Name: php-ZendFramework
-Version: 1.12.17
+Version: 1.12.18
Release: 1%{?posttag}%{?dist}
License: BSD
@@ -673,7 +673,8 @@ ln -s %{_datadir}/php/Zend/zf.sh \
%files extras
%defattr(-,root,root,-)
%{_datadir}/php/ZendX
-%exclude %{_datadir}/php/ZendX/Db
+%exclude %{_datadir}/php/ZendX/Db/Adapter/*
+%exclude %{_datadir}/php/ZendX/Db/Statement/*
%license LICENSE.txt
%endif
@@ -854,6 +855,11 @@ ln -s %{_datadir}/php/Zend/zf.sh \
%changelog
+* Thu Apr 14 2016 Remi Collet <remi@remirepo.net> - 1.12.18-1
+- update to 1.12.18
+- extras and Db-Adapter-Firebird sub packages are back
+- Youtube support is dropped
+
* Wed Nov 25 2015 Remi Collet <remi@remirepo.net> - 1.12.17-1
- update to 1.12.17
- extras and Db-Adapter-Firebird sub packages are no