summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json20
-rw-r--r--php-yoast-phpunit-polyfills3.spec15
2 files changed, 18 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index ba28086..7495f94 100644
--- a/composer.json
+++ b/composer.json
@@ -54,7 +54,7 @@
},
"extra": {
"branch-alias": {
- "dev-main": "3.x-dev"
+ "dev-main": "4.x-dev"
}
},
"scripts": {
@@ -67,9 +67,6 @@
"lint-gte80": [
"@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --show-deprecated --exclude vendor --exclude .git"
],
- "lint-gte84": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --show-deprecated --exclude vendor --exclude .git"
- ],
"check-cs": [
"@php ./vendor/squizlabs/php_codesniffer/bin/phpcs --runtime-set testVersion 7.0-"
],
@@ -82,23 +79,22 @@
"coverage": [
"@php ./vendor/phpunit/phpunit/phpunit"
],
- "test10": [
- "@php ./vendor/phpunit/phpunit/phpunit -c phpunit10.xml.dist --no-coverage"
+ "test11": [
+ "@php ./vendor/phpunit/phpunit/phpunit -c phpunit11.xml.dist --no-coverage"
],
- "coverage10": [
- "@php ./vendor/phpunit/phpunit/phpunit -c phpunit10.xml.dist"
+ "coverage11": [
+ "@php ./vendor/phpunit/phpunit/phpunit -c phpunit11.xml.dist"
]
},
"scripts-descriptions": {
"lint7": "Check the PHP files for parse errors. (PHP 7.1 - 7.4)",
"lint70": "Check the PHP files for parse errors. (PHP 7.0)",
- "lint-gte80": "Check the PHP files for parse errors. (PHP 8.0 - 8.3)",
- "lint-gte84": "Check the PHP files for parse errors. (PHP 8.4+)",
+ "lint-gte80": "Check the PHP files for parse errors. (PHP 8.0+)",
"check-cs": "Check the PHP files for code style violations and best practices.",
"fix-cs": "Auto-fix code style violations in the PHP files.",
"test": "Run the unit tests without code coverage (PHPUnit < 10).",
"coverage": "Run the unit tests with code coverage (PHPUnit < 10).",
- "test10": "Run the unit tests without code coverage using the PHPUnit 10/11 configuration file.",
- "coverage10": "Run the unit tests with code coverage using the PHPUnit 10/11 configuration file."
+ "test11": "Run the unit tests without code coverage using the PHPUnit 11 configuration file.",
+ "coverage11": "Run the unit tests with code coverage using the PHPUnit 11 configuration file."
}
}
diff --git a/php-yoast-phpunit-polyfills3.spec b/php-yoast-phpunit-polyfills3.spec
index b586132..46f8999 100644
--- a/php-yoast-phpunit-polyfills3.spec
+++ b/php-yoast-phpunit-polyfills3.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit 59b3f8ffa2eab9c8258e8638d97c3e37fac9a80e
+%global gh_commit 9cf2ccd990eadfc4a1e390592d4731e590b2c618
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -22,8 +22,8 @@
%bcond_without tests
%global php_home %{_datadir}/php
-Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.1.0
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.1.2
Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality, version %{major}
@@ -39,9 +39,10 @@ BuildRequires: php(language) >= 7.0
BuildRequires: php-reflection
# From composer.json, "require-dev": {
# "yoast/yoastcs": "^2.3.0"
-# remirepo:1
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
BuildRequires: phpunit11
-# phpunit10 is not supported
+%endif
+# phpunit10/phpunit12 are not supported
BuildRequires: phpunit9
BuildRequires: phpunit8
%endif
@@ -128,6 +129,10 @@ exit $ret
%changelog
+* Mon Feb 10 2025 Remi Collet <remi@remirepo.net> - 3.1.2-1
+- update to 3.1.2
+- rename to php-yoast-phpunit-polyfills3 (compat package)
+
* Thu Jan 9 2025 Remi Collet <remi@remirepo.net> - 3.1.0-1
- update to 3.1.0
- re-license spec file to CECILL-2.1