summaryrefslogtreecommitdiffstats
path: root/php-yoast-phpunit-polyfills.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-04-09 08:48:07 +0200
committerRemi Collet <remi@php.net>2024-04-09 08:48:07 +0200
commitd28a1fbe8fdd08c32b3a2d95e54fbdaa218934ed (patch)
treef2f853a5de3a2387ee0775845a6f944c248f01f4 /php-yoast-phpunit-polyfills.spec
parent7b13e26617654e306134e88882c244a1ac0a9ce3 (diff)
update to 1.1.1HEADmaster
Diffstat (limited to 'php-yoast-phpunit-polyfills.spec')
-rw-r--r--php-yoast-phpunit-polyfills.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index a13f7dd..7660597 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-yoast-phpunit-polyfills
#
-# Copyright (c) 2020-2023 Remi Collet
+# Copyright (c) 2020-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please preserve changelog entries
#
# Github
-%global gh_commit 3b59adeef77fb1c03ff5381dbb9d68b0aaff3171
+%global gh_commit a0f7d708794a738f328d7b6c94380fd1d6c40446
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.0.5
+Version: 1.1.1
Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality
@@ -91,21 +91,18 @@ EOF
: Run upstream test suite
ret=0
-if [ -x %{_bindir}/phpunit ]; then
- %{_bindir}/phpunit --no-coverage || ret=1
-fi
if [ -x %{_bindir}/phpunit7 ]; then
%{_bindir}/phpunit7 --no-coverage || ret=1
fi
if [ -x %{_bindir}/phpunit8 ]; then
- for cmd in php php80 php81 php82; do
+ for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd %{_bindir}/phpunit8 --no-coverage || ret=1
fi
done
fi
if [ -x %{_bindir}/phpunit9 ]; then
- for cmd in php php80 php81 php82; do
+ for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --no-coverage || ret=1
fi
@@ -126,6 +123,9 @@ exit $ret
%changelog
+* Tue Apr 9 2024 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Fri Mar 31 2023 Remi Collet <remi@remirepo.net> - 1.0.5-1
- update to 1.0.5