summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-21 07:19:43 +0200
committerRemi Collet <remi@remirepo.net>2021-06-21 07:19:43 +0200
commit8d40fb6bb6895b9b188e21a5615ebadff5f3a726 (patch)
tree57fbc9e64071600c3e3cbb1751ad495cda2b8e5f
parent316b31c0771fcae9ecb866227197f1ebee9c655b (diff)
update to 1.0.0
-rw-r--r--composer.json17
-rw-r--r--php-yoast-phpunit-polyfills-layout.patch11
-rw-r--r--php-yoast-phpunit-polyfills.spec22
3 files changed, 20 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index ece8171..5cf9d22 100644
--- a/composer.json
+++ b/composer.json
@@ -23,11 +23,11 @@
"minimum-stability": "dev",
"prefer-stable": true,
"require": {
- "php": ">=5.5",
+ "php": ">=5.4",
"phpunit/phpunit": "^4.8.36 || ^5.7.21 || ^6.0 || ^7.0 || ^8.0 || ^9.0"
},
"require-dev": {
- "php-parallel-lint/php-parallel-lint": "^1.2.0",
+ "php-parallel-lint/php-parallel-lint": "^1.3.0",
"php-parallel-lint/php-console-highlighter": "^0.5",
"yoast/yoastcs": "^2.1.0"
},
@@ -46,14 +46,17 @@
}
},
"scripts": {
- "lint": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git"
+ "lint7": [
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git --exclude src/Exceptions/Error.php --exclude src/Exceptions/TypeError.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
+ ],
+ "lint-lt70": [
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git --exclude src/TestCases/TestCasePHPUnitGte8.php --exclude src/TestListeners/TestListenerDefaultImplementationPHPUnitGte7.php --exclude tests/Polyfills/Fixtures/ChildValueObject.php --exclude tests/Polyfills/Fixtures/ValueObject.php --exclude tests/Polyfills/Fixtures/ValueObjectUnion.php --exclude tests/Polyfills/Fixtures/ValueObjectUnionNoReturnType.php"
],
- "lint-lt71": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git --exclude src/TestCases/TestCasePHPUnitGte8.php --exclude src/TestListeners/TestListenerDefaultImplementationPHPUnitGte7.php"
+ "lint-gte80": [
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php --exclude vendor --exclude .git"
],
"check-cs": [
- "@php ./vendor/squizlabs/php_codesniffer/bin/phpcs"
+ "@php ./vendor/squizlabs/php_codesniffer/bin/phpcs --runtime-set testVersion 5.4-"
],
"fix-cs": [
"@php ./vendor/squizlabs/php_codesniffer/bin/phpcbf"
diff --git a/php-yoast-phpunit-polyfills-layout.patch b/php-yoast-phpunit-polyfills-layout.patch
deleted file mode 100644
index 637d51b..0000000
--- a/php-yoast-phpunit-polyfills-layout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up ./phpunitpolyfills-autoload.php.rpm ./phpunitpolyfills-autoload.php
---- ./phpunitpolyfills-autoload.php.rpm 2020-11-26 07:45:13.798777427 +0100
-+++ ./phpunitpolyfills-autoload.php 2020-11-26 07:45:29.603748277 +0100
-@@ -88,7 +88,6 @@ if ( \class_exists( 'Yoast\PHPUnitPolyfi
- default:
- $file = \realpath(
- __DIR__ . \DIRECTORY_SEPARATOR
-- . 'src' . \DIRECTORY_SEPARATOR
- . \strtr( \substr( $class, 23 ), '\\', \DIRECTORY_SEPARATOR ) . '.php'
- );
-
diff --git a/php-yoast-phpunit-polyfills.spec b/php-yoast-phpunit-polyfills.spec
index 9a04f44..b6830f3 100644
--- a/php-yoast-phpunit-polyfills.spec
+++ b/php-yoast-phpunit-polyfills.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit c48e4cf0c44b2d892540846aff19fb0468627bab
+%global gh_commit 5d257d5a6977137016f3df440ce640ce72ffd61a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Yoast
%global gh_project PHPUnit-Polyfills
@@ -23,8 +23,8 @@
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 0.2.0
-Release: 2%{?dist}
+Version: 1.0.0
+Release: 1%{?dist}
Summary: Set of polyfills for changed PHPUnit functionality
License: BSD
@@ -33,15 +33,12 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# autoloader relocated in src tree
-Patch0: %{name}-layout.patch
-
BuildArch: noarch
%if %{with tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.4
BuildRequires: php-reflection
# From composer.json, "require-dev": {
-# "php-parallel-lint/php-parallel-lint": "^1.2.0",
+# "php-parallel-lint/php-parallel-lint": "^1.3.0",
# "php-parallel-lint/php-console-highlighter": "^0.5",
# "yoast/yoastcs": "^2.1.0"
%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
@@ -50,16 +47,15 @@ BuildRequires: phpunit9
BuildRequires: phpunit8
%if 0%{?fedora} < 35 && 0%{?rhel} < 9
BuildRequires: phpunit7
-BuildRequires: phpunit6
BuildRequires: phpunit
%endif
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer.json, "require": {
-# "php": ">=5.5",
+# "php": ">=5.4",
# "phpunit/phpunit": "^4.8.36 || ^5.7.21 || ^6.0 || ^7.0 || ^8.0 || ^9.0"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.4
# from phpcompatinfo report on version 0.2.0
Requires: php-reflection
@@ -78,7 +74,6 @@ Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%setup -q -n %{gh_project}-%{gh_commit}
# Fix for RPM layout
-%patch0 -p1 -b .rpm
sed -e 's:src/::' phpunitpolyfills-autoload.php > src/autoload.php
@@ -154,6 +149,9 @@ exit $ret
%changelog
+* Mon Jun 21 2021 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+
* Wed Mar 10 2021 Remi Collet <remi@remirepo.net> - 0.2.0-2
- reduce build matrix