summaryrefslogtreecommitdiffstats
path: root/php-williamdes-mariadb-mysql-kbs.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-27 08:39:12 +0100
committerRemi Collet <remi@remirepo.net>2020-01-27 08:39:12 +0100
commit58c0bc2d7a8b221a0ad28d7a47b95cf5a64e6fc9 (patch)
tree743601a961766464e2871f2e2e61c07f5d4468eb /php-williamdes-mariadb-mysql-kbs.spec
parent529a4aa76afea16c9138bba22d604b5eed3f21f3 (diff)
update to 1.2.9
switch to phpunit8
Diffstat (limited to 'php-williamdes-mariadb-mysql-kbs.spec')
-rw-r--r--php-williamdes-mariadb-mysql-kbs.spec25
1 files changed, 14 insertions, 11 deletions
diff --git a/php-williamdes-mariadb-mysql-kbs.spec b/php-williamdes-mariadb-mysql-kbs.spec
index 417cc97..b654a98 100644
--- a/php-williamdes-mariadb-mysql-kbs.spec
+++ b/php-williamdes-mariadb-mysql-kbs.spec
@@ -9,7 +9,7 @@
%global with_tests 0%{!?_without_tests:1}
# Github
-%global gh_commit ebae1986d3dec93df3bdf9ae5c664485c12d2b94
+%global gh_commit 0da5be5f43c184f497c84e4865c9fd8f37f19d5d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner williamdes
%global gh_project mariadb-mysql-kbs
@@ -22,7 +22,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.2.8
+Version: 1.2.9
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: An index of the MariaDB and MySQL Knowledge bases
@@ -38,14 +38,13 @@ BuildRequires: php(language) >= 7.1
BuildRequires: php-json
BuildRequires: php-pcre
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^7.0 || ^8.0",
-# "phpstan/phpstan": "^0.11.3",
-# "slevomat/coding-standard": "^5.0",
+# "phpunit/phpunit": "^7 || ^8",
+# "phpstan/phpstan": "^0.12",
+# "slevomat/coding-standard": "^6.0",
# "squizlabs/php_codesniffer": "^3.3",
-# "php-school/cli-menu": "^3.0",
# "swaggest/json-schema": "^0.12.9"
-BuildRequires: phpunit7
-%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit8
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(swaggest/json-schema) > 0.12.9 with php-composer(swaggest/json-schema) < 1)
%else
@@ -78,7 +77,8 @@ Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
+%patch0 -p1 -b .rpm
+find src -name \*.rpm -delete
: Create autoloader
cat <<'AUTOLOAD' | tee src/autoload.php
@@ -118,11 +118,10 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
require '%{_datadir}/php/Swaggest/JsonSchema/autoload.php';
EOF
-cd test
export RPM_BUILDROOT=%{buildroot}
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{phpunit} --no-coverage --verbose || ret=1
fi
@@ -150,6 +149,10 @@ exit $ret
%changelog
+* Mon Jan 27 2020 Remi Collet <remi@remirepo.net> - 1.2.9-1
+- update to 1.2.9
+- switch to phpunit8
+
* Tue Nov 12 2019 Remi Collet <remi@remirepo.net> - 1.2.8-1
- update to 1.2.8