summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-04 10:46:19 +0100
committerRemi Collet <remi@remirepo.net>2021-01-04 10:46:19 +0100
commitb193218c3aa841b328f998814b52567b4b247e79 (patch)
tree5176d814ec5ed78158d9eee5ad24a8e264cac7c9
parente25dee4545c89d4380108cca8251bd07eb4d9c57 (diff)
update to 1.2.12
-rw-r--r--composer.json4
-rw-r--r--php-williamdes-mariadb-mysql-kbs.spec14
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index be5ef71..653b936 100644
--- a/composer.json
+++ b/composer.json
@@ -5,7 +5,7 @@
"type": "library",
"readme": "https://github.com/williamdes/mariadb-mysql-kbs/blob/main/README.md",
"license": "MPL-2.0",
- "version": "1.2.11",
+ "version": "1.2.12",
"keywords": [
"mariadb",
"mysql",
@@ -38,7 +38,7 @@
"phpcbf": "phpcbf --standard=phpcs.xml"
},
"require": {
- "php": ">=7.1"
+ "php": "^7.1 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^7 || ^8 || ^9",
diff --git a/php-williamdes-mariadb-mysql-kbs.spec b/php-williamdes-mariadb-mysql-kbs.spec
index 8bbbda3..25ec517 100644
--- a/php-williamdes-mariadb-mysql-kbs.spec
+++ b/php-williamdes-mariadb-mysql-kbs.spec
@@ -1,15 +1,16 @@
# remirepo/fedora spec file for php-williamdes-mariadb-mysql-kbs
#
-# Copyright (c) 2019-2020 Remi Collet
+# Copyright (c) 2019-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
+
# Github
-%global gh_commit 2653637d537329b2b2ba7290dc70eacf09c74072
+%global gh_commit b5d4b498ba3d24ab7ad7dd0b79384542e37286a1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner williamdes
%global gh_project mariadb-mysql-kbs
@@ -22,7 +23,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.2.11
+Version: 1.2.12
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: An index of the MariaDB and MySQL Knowledge bases
@@ -63,7 +64,7 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": ">=7.1"
+# "php": "^7.1 || ^8.0"
Requires: php(language) >= 7.1
# From phpcompatinfo report for 1.2.7
Requires: php-json
@@ -157,6 +158,9 @@ exit $ret
%changelog
+* Mon Jan 4 2021 Remi Collet <remi@remirepo.net> - 1.2.12-1
+- update to 1.2.12
+
* Mon Sep 14 2020 Remi Collet <remi@remirepo.net> - 1.2.11-1
- update to 1.2.11
- switch to phpunit9